Fordmods Logo

Very Odd light problem 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: Very Odd light problem
Posted: Tue May 27, 2008 7:31 pm 
Oompa Loompa
Offline

Age: 28

Posts: 36

Joined: 31st Mar 2007

Location: Adelaide
SA, Australia

Ive got an EF Falcon 95... Just had a problem. I resprayed my car, and when it got cut and polished, the bloke i took it to fixed my left hand side Window.

Now since that happened, whenever i put in my back door lights (at the top) my 20amp fuse for the cruise control goes! And when those lights are in, my fuel pump doesn't send fuel to the engine, my cd player and dash doesn't work (as well as my electric windows) But when i take it out it works fine.. Does anybody know what that could be? Its driving me insane!
Top
 Profile  
 
 
Posted: Tue May 27, 2008 8:12 pm 
Stock as a Rock
Offline

Posts: 189

Joined: 5th Mar 2007

Ride: 94 Futura

Location: Midland
WA, Australia

Have you got the wiring diagram(s)?
Start by finding why the 20A fuse goes. That should be straightforward.
Sounds like a couple of wires are swapped or damaged.
Cheers,
C
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 5:01 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names