Fordmods Logo

Why won't trip comp work with EL ecu? 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: Why won't trip comp work with EL ecu?
Posted: Thu May 03, 2007 11:45 pm 
Getting Side Ways
Offline
User avatar

Posts: 653

Joined: 2nd May 2006

Gallery: 1 images

Ride: FG G6E Turbo

Location: Melbourne
VIC, Australia

I have read several thread regarding how EA-ED trip computer and EL ECU doesn't work, I was wondering if someone could tell me why i will get errors and how do I fix it if possible

 

_________________

FG G6E Turbo
Grandpa Spec!

Last edited by bArNsY on Thu May 03, 2007 11:47 pm, edited 1 time in total.

Top
 Profile  
 
 
 Post subject: Re: Why won't trip comp work with EL ecu?
Posted: Thu May 03, 2007 11:46 pm 
Getting Side Ways
Offline
User avatar

Posts: 653

Joined: 2nd May 2006

Gallery: 1 images

Ride: FG G6E Turbo

Location: Melbourne
VIC, Australia

double post

 

_________________

FG G6E Turbo
Grandpa Spec!

Top
 Profile  
 
 
Posted: Fri May 04, 2007 12:06 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2833

Joined: 7th Nov 2004

Gallery: 4 images

Ride: Lincoln LS, MKII Escort, ED

Location: geelong
VIC, Australia

EA-ED relies on a signal coming from the ECU which tells it what pulse width the injectors are running at, it then uses this info (and fule level and current fuel load) to calculate L100 and Distance

in EF above this information comes from the CAN bus which the tripcomp cant understand.

Ive heard someone mention that you can trick the tripcomp into working (id suspect you may be able to tap into the injector loom to directly acess the PWM info)

 

_________________

Because i can.

Top
 Profile  
 
 
Posted: Fri May 04, 2007 12:23 am 
Site Admin
Offline
User avatar

Age: 34

Posts: 8831

Joined: 18th Dec 2002

Gallery: 6 images

Ride: AUII V8 LTD

Power: 270 rwkw

Location: Sydney
NSW, Australia

Look at the EA-ED trip computer install doco, it might have a few hints as to all the inputs that the EA-ED trip computer requires.

You should be able to get it working..

 

_________________

WAG363: AUII LTD Supercharged 363 Dart Stroker [Supercharged 363 LTD Build]
WAGGIN: 2012 Volkswagen Passat Wagon - V6 4Motion.

Top
 Profile  
 
 
 Post subject: Why won't trip comp work with EL ecu?
Posted: Fri May 04, 2007 8:43 am 
Smokin em up
Offline

Age: 59

Posts: 247

Joined: 6th May 2006

Gallery: 29 images

Location: Victoria
VIC, Australia

Hey guys. I just completed my BBM conversion using an EL ECU on my ED and yeah, the trip computer doesn't work properly either. The only thing that really doesn't work is the instant reading, because as previously mentioned, they speak a different language, so the instant readings are sitting at between 85 and 99 on mine!!! :shock:

As a result, it thinks I'm using AVG 88.7 l/100km and it beeps at me to say 60km DTE when I have nearly 3/4 tank :roll:

The AVG km/h input still works, as do all of the buzzers, ie lights on after ignition off.

But it was said you can just tap into the injector loom to get the PWM, and use that to connect to trip computer rather than from ECU data line. Will save me from pressing RESET on TC every time I start my car.

Do you have anymore info where I could do that, coz I'll probably get out right now while on annual leave and get it going. There'll be heaps of guys interested with BBM conversions.

Cheers,

Mark.
Top
 Profile  
 
 
 Post subject: Re: Why won't trip comp work with EL ecu?
Posted: Fri May 04, 2007 7:00 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2833

Joined: 7th Nov 2004

Gallery: 4 images

Ride: Lincoln LS, MKII Escort, ED

Location: geelong
VIC, Australia

MyEDFalcon6 wrote:
Hey guys. I just completed my BBM conversion using an EL ECU on my ED and yeah, the trip computer doesn't work properly either. The only thing that really doesn't work is the instant reading, because as previously mentioned, they speak a different language, so the instant readings are sitting at between 85 and 99 on mine!!! :shock:

As a result, it thinks I'm using AVG 88.7 l/100km and it beeps at me to say 60km DTE when I have nearly 3/4 tank :roll:

The AVG km/h input still works, as do all of the buzzers, ie lights on after ignition off.

But it was said you can just tap into the injector loom to get the PWM, and use that to connect to trip computer rather than from ECU data line. Will save me from pressing RESET on TC every time I start my car.

Do you have anymore info where I could do that, coz I'll probably get out right now while on annual leave and get it going. There'll be heaps of guys interested with BBM conversions.

Cheers,

Mark.


if youve got a digital multi meter that does PWM readings, you could put the ED ECU back in, and compare the tripcomp pin # 5 "5 Green/Yellow To fuel injection PWM output on EEC-IV " with the injector loom (for voltage and PWM reading, if they are even remotely similar it should work

 

_________________

Because i can.

Top
 Profile  
 
 
Posted: Fri May 04, 2007 7:35 pm 
Getting Side Ways
Offline
User avatar

Posts: 6168

Joined: 5th Nov 2004

rip the guts outta a ef/el one and shove it in?

 

_________________

Image

Top
 Profile  
 
 
Posted: Mon May 07, 2007 10:06 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 497

Joined: 5th Nov 2004

Gallery: 11 images

Ride: 1989 300ZX Twin turbo Z32

Location: Bardon, Brisbane
QLD, Australia

hey guys. i've been doing a bit of research on this topic. i see that the el ecu pin 17 is a pwm self test output signal. I wonder if tapping into this instead of the normal pin 34 would work on eb trip computers with el ecu? Or is it likely to be a different type of pwm signal?

 

_________________

Sold my EB :(
Now got my 300zx :)

Top
 Profile  
 
 
Posted: Mon May 07, 2007 10:28 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

it sounds like it should work, but im not 100 % sure. i guess at worst it will blow up your trip computer
Top
 Profile  
 
 
Posted: Tue Jul 03, 2007 11:41 pm 
Smokin em up
Offline

Age: 54

Posts: 218

Joined: 12th Jun 2005

Location: hobart
TAS, Australia

conect the green/yellow wire from pin 34 (el ecu) to pin 58 brown wire , pull fuse to reset ed trip computer all works fine in my nc fairlane 4.0 (was eec-iv now eec-v)

 

_________________

NC2 Fairlane AU2 Intech 4.0 Wolf V500 ECU Accel 500cc Injectors Eaton M90 Blower MPx Porting 75mm Mustang TB Intercooler Holley 255lph EL XR6 Rear End 3.45 LSD Duel Fuel lots more.
Long and Very Nice

Top
 Profile  
 
 
Posted: Mon Jul 16, 2007 5:24 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 497

Joined: 5th Nov 2004

Gallery: 11 images

Ride: 1989 300ZX Twin turbo Z32

Location: Bardon, Brisbane
QLD, Australia

xfpaul wrote:
conect the green/yellow wire from pin 34 (el ecu) to pin 58 brown wire , pull fuse to reset ed trip computer all works fine in my nc fairlane 4.0 (was eec-iv now eec-v)


just tried this with my eb running el ecu. works a treat. thanks xfpaul!

 

_________________

Sold my EB :(
Now got my 300zx :)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 7:27 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names