Fordmods Logo

AU s2 really low rpm 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: AU s2 really low rpm
Posted: Sun May 10, 2009 12:15 am 
Fordmods Newbie
Offline

Age: 35

Posts: 4

Joined: 16th Apr 2009

Ride: 96 EL gli falcon

Location: Perth
WA, Australia

Hey guys just wondering if anyone can help

My wifes au2 has severe drop in revs when we come off throttle into a corner. it drops low enough make steering heavy.

any tips would be great.

 

_________________

Hail the mighty Blue Oval!!

Top
 Profile  
 
 
 Post subject: Re: AU s2 really low rpm
Posted: Sun May 10, 2009 3:13 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 2159

Joined: 15th Nov 2005

Gallery: 17 images

Ride: TS40

Location: Latrobe Valley
VIC, Australia

I'd check/clean the IAC/ISC valve, and also the power steering switch. mine was doing the same thing, stalled a couple of time... i just cleaned the whole throttle body and isc valve with carby/throttle body cleaner... working fine now...

is the AU Auto or Manual? mines manual but iv head of issues with the auto clutch not disengaging in time?

 

_________________

Was - 2001 AUIII Ford Falcon Forte
Genuine T2 TS50 bodykit, 18" BF Cobras, Boge and Eibach Suspension and Complete AU2 Fairmont Ghia Interior

Now - 2012 FG Mk2 Ford Falcon XR6
Swift Green,6 Speed Auto, Stock... and a Fuel Card :)

Top
 Profile  
 
 
 Post subject: Re: AU s2 really low rpm
Posted: Thu May 14, 2009 9:23 pm 
Getting Side Ways
Offline

Age: 48

Posts: 429

Joined: 3rd Jan 2005

Ride: AU XR6 with BF Turbo engine

Location: Sydney
NSW, Australia

depending on the system installed, the balance line might of been disconnected

 

_________________

RIP :( 1x confused Falcon..EL Falcon with full AU running gear...VCT, 5 speed, IRS, AUII front suspension, brakes, and steering RIP

Top
 Profile  
 
 
 Post subject: Re: AU s2 really low rpm
Posted: Mon May 25, 2009 10:20 pm 
Getting Side Ways
Offline

Posts: 6449

Joined: 11th Nov 2004

ours would do it only turning left.
mixtures were not right.

i spent the weekend with gas ECU disabled and a wideband O2 sensor fitted.
Adjusted everything to have the mixtures as close to perfect as i could, that way when the ECU was reconnected it had only small adjustments to make.
fixed the stalling, fixed the backfire, and netted me and extra 80km to a tank.
Also found out that it goes lean at revs and could not be made richer.

 

_________________

PERMANENTLY BANNED

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot], Yahoo [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 7:56 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names