Fordmods Logo

EL Acting Strange on Petrol 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: EL Acting Strange on Petrol
Posted: Thu Oct 15, 2009 7:52 pm 
Smokin em up
Offline

Posts: 299

Joined: 19th Aug 2007

Location: Port Augusta
SA, Australia

Hello,
New here so please be nice :P

I have an EL Falcon Automatic on Dual Fuel (Non Factory and dont know the brand or insataller sorry)
It runs really nice on Gas, smooth and great economy (according to the trip meter 6.0 l/100km on the highway at 100km/h) but on petrol its a strange thing.

If i accelerate hard or softly its really rough until 2000/2200 rpm or so with no guts at all. After that it takes off and runs really smoothly. Could this be a fuel pressure problem or is it something as a fuel filter or blocked injectors? A mechanic said to me that dual fuel cars just get like this, not sure if i totaly believe that... The car has been doing this since i bought it.

I have tried different fuel types and generally run 98, the only thing i have been able to try is injector cleaner. Would like to know a few ideas about what could be wrong. Any help is much appreshiated!
Top
 Profile  
 
 
 Post subject: Re: EL Acting Strange on Petrol
Posted: Thu Oct 15, 2009 8:00 pm 
Fordmods Junkie
Offline
User avatar

Age: 35

Posts: 3045

Joined: 26th Nov 2008

Ride: 1975 XB Falcon 500

Location: In the drivers seat
SA, Australia

jrloz wrote:
Hello,
New here so please be nice :P

I have an EL Falcon Automatic on Dual Fuel (Non Factory and dont know the brand or insataller sorry)
It runs really nice on Gas, smooth and great economy (according to the trip meter 6.0 l/100km on the highway at 100km/h) but on petrol its a strange thing.

If i accelerate hard or softly its really rough until 2000/2200 rpm or so with no guts at all. After that it takes off and runs really smoothly. Could this be a fuel pressure problem or is it something as a fuel filter or blocked injectors? A mechanic said to me that dual fuel cars just get like this, not sure if i totaly believe that... The car has been doing this since i bought it.

I have tried different fuel types and generally run 98, the only thing i have been able to try is injector cleaner. Would like to know a few ideas about what could be wrong. Any help is much appreshiated!


So its idling like a bucket of s**t on petrol? I have had this and it ended up being the vacuum hose on the PCV valve on the rocker cover have come off. Check all of your vacuum hoses around the injection manifold. Check to see if any have come off or splits etc.

LPG is more forgiving witch is why its running better on gas.

Hope this helps.

 

_________________

Image
http://www.facebook.com/Ford1975

Top
 Profile  
 
 
 Post subject: Re: EL Acting Strange on Petrol
Posted: Sun Oct 18, 2009 5:56 pm 
Fordmods Newbie
Offline

Posts: 5

Joined: 2nd Mar 2009

Ride: Ford Falcon EF

Location: Candberra
ACT, Australia

jrloz wrote:
If i accelerate hard or softly its really rough until 2000/2200 rpm or so with no guts at all. After that it takes off and runs really smoothly.

I had a similar problem with EF. The car use to run fine on petrol, then one day the car just didn't want to accelerate on petrol...had a sort of hesitation under load. I thought bad fuel, or injectors, or fuel pressure. I tried a few goes with injector cleaner, but it never got any better. In fact, during winter it was better, than summer.

I then had an odd problem on LPG, with the very occasional stall. This turned out to be the Tacho Amp module that they connect when fitting the LPG. Once this was replaced, the car ran fine on gas, and interestingly, it is now running on petrol much better.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 1:42 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names