Fordmods Logo

EL falcon on gas is rough idling and missing 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: EL falcon on gas is rough idling and missing
Posted: Thu Jul 09, 2009 2:29 am 
Fordmods Newbie
Offline

Posts: 9

Joined: 9th Jul 2009

Ride: EL Falcon

Location: Sydney- west
NSW, Australia

Hey guys.

i was having trouble with my EL falcon. it seems to be idling very very rough and it shivers and it is missing aswell.

a week earlier it died on me and i had the distributor changed. and the coils.

it went away for a while then came back,

i have checked in the dark i have read the subject up a fair bit its sparks arent arcing in the dark. i was looking for some help on the topic. its been doing this for ages and ive been told its no big problem but its getting really really annoying! and i really want to get rid of it.

thanks in advance guys.

oh by the way guys its a duel fuel model and on rough idle sometimes the whole car shivers and shakes like crazy...

some say its the converter thats gone dirty on the inside and needs a good clean.
some say that i should change the sparks and the leads
some say that i should clean the throttle body

any hints would be great.

cheers guys.
Top
 Profile  
 
 
 Post subject: Re: EL falcon on gas is rough idling and missing
Posted: Mon Jul 13, 2009 11:09 pm 
Fordmods Newbie
Offline

Age: 42

Posts: 2

Joined: 13th May 2009

Ride: Ford EF Falcon

Location: Brisbane
QLD, Australia

Not sure if this will help, but have you considered checking the ECU, perhaps swapping it with a known good one to test? I've had similar problems since converting my EF to dual fuel, specifically an erratic idle while running on petrol. I'm looking for a replacement ECU to fix it. Perhaps this might work for you too.
Top
 Profile  
 
 
 Post subject: Re: EL falcon on gas is rough idling and missing
Posted: Mon Jul 13, 2009 11:15 pm 
Getting Side Ways
Offline

Age: 26

Posts: 428

Joined: 21st Feb 2009

Gallery: 1 images

Ride: BA XR6, EA Brock Falcon

Location: Drouin
VIC, Australia

hey mate i had the same problem as you. but my car wouldnt start or run on gas. i got the leads and the plugs changed and it runs on gas now but idles rough and shakes like bugery when the revs drop. im getting it checked out tomorow so ill let u know what happens.
Top
 Profile  
 
 
 Post subject: Re: EL falcon on gas is rough idling and missing
Posted: Tue Jul 14, 2009 5:26 pm 
Getting Side Ways
Offline
User avatar

Posts: 633

Joined: 21st Nov 2008

Location: Melbourne
VIC, Australia

new plugs, leads, rotor and cap for starters is a must, then get the gas tuned by a specialized gas installer/tuner
Top
 Profile  
 
 
 Post subject: Re: EL falcon on gas is rough idling and missing
Posted: Sat Jul 18, 2009 7:49 pm 
Fordmods Newbie
Offline

Posts: 9

Joined: 9th Jul 2009

Ride: EL Falcon

Location: Sydney- west
NSW, Australia

okay huge update guys...

sorry have been away from the comp for quiet a while...

now.. i solved the issue thanks to this forums brilliant minds... my dads a procrastinator hes way too busy so i got around to it myself...

First i bought some WYNNS Fuel injector cleaner... which helped quiet a fair bit.. ran it on petrol.. i used the 300ml bottle in about 20 litres instead of 50

that fixed a fair bit of the problem.. but just to be sure..

i bought some throttle body cleaner... cleaned the MAP sensor.. then had a crack at the throttle body sensor then the ICS Idle something something... once all that was done i cleaned some of the obvious vacuum lines i could see with the throttle body cleaner..

and yeah. that takes care of my crazy idle issues.. where the idle jumps like crazy up and down..

although on petrol its still very dead-laggy umm not responsive etc? upto 2500rpm but i think thats the timing and doesnt run too great on petrol but way better than before...

LPG runs great.. no problems at all..

IDLE IS GREAT SMOOTH and sexy lol.

and gonna do a comprehensive clean (MAYBE) of the lpg converter anyway..

now there were some things that still are wrong..

the engine is ticking.. i think its the lifters? or its the spark plugs/leads... gonna get around to taking a look at them tommorow.. and the engine is sortof moving about a fair bit ie not totally shaking but just a tiny bit & thats at standstill...

but something is ticking ...
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 10:57 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names