Fordmods Logo

EL Tickford Factory Gas Stall When Slowing Down 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: EL Tickford Factory Gas Stall When Slowing Down
Posted: Sat Jul 05, 2008 4:09 pm 
Fordmods Newbie
Offline

Posts: 3

Joined: 21st Jun 2008

Ride: Falcon

Location: gold coast
QLD, Australia

Hi, I have an EL with the factory tickford gas system from vialle. It runs perfectly in the driveway but everytime I take it for a drive it stalls when I try to slow down. I have checked the stepper, the diaphrams in the converter, have reset the ams. Ford won't tell me anything about the system and the local gas shops are falling over themselves to charge me $1,000 to fit a new converter but when queried about the nature of the problem seem to be clueless. Any advice would be welcome.
Top
 Profile  
 
 
Posted: Sat Jul 05, 2008 6:57 pm 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

Check the balance tube for leaks , even pin holes can cause problems. Next the idle solenoid valve could need a clean.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Sat Jul 05, 2008 7:23 pm 
Fordmods Newbie
Offline

Age: 31

Posts: 4

Joined: 25th Jun 2008

Ride: Falcon

Location: geelong
VIC, Australia

Mine had the same problem, turned out the air intake manifold was cracked along the seam due to a back fire, so the air mix was obviously wrong. same symptoms as yours but i dont know wether its the same problem. Good luck mate

 

_________________

----------------------------------------------------
I'd rather die on my feet than live on my knees

Top
 Profile  
 
 
Posted: Sat Jul 05, 2008 11:14 pm 
Getting Side Ways
Offline
User avatar

Posts: 3363

Joined: 27th Dec 2004

Gallery: 4 images

Ride: MCMXCV Falcon

Location: G town
VIC, Australia

twason wrote:
Check the balance tube for leaks , even pin holes can cause problems. Next the idle solenoid valve could need a clean.


i here this balancer line thing being used as the excuse for everything.....is that the tube that runs from the convertor to the airbox? I am running without an airbox, just straight into the mixer and ive noticed sweet f**k all difference.....

yeah youd want to be checking for vacume leaks in the entire intake system (including manifold to head bolts)....maybe u can bump the idle up a little and also check the ring hasnt become dislodged in the rubber elbow....

after these and other basic checks such as ignition i would only then look at the converter

 

_________________

Image

Top
 Profile  
 
 
Posted: Sun Jul 06, 2008 10:35 am 
Fordmods Newbie
Offline

Posts: 3

Joined: 21st Jun 2008

Ride: Falcon

Location: gold coast
QLD, Australia

I forgot to mention that the car runs perfectly on petrol. Are there any problems that will affect the lpg like this but won't show up when using petrol.
Top
 Profile  
 
 
Posted: Sun Jul 06, 2008 12:22 pm 
Smokin em up
Offline

Age: 57

Posts: 213

Joined: 6th Nov 2004

Ride: Falcon RTV

Location: Maryborough
QLD, Australia

Clean your idle jet out, its under a solenoid on top of the converter. You will need some long fine wire to reach inside to unblock it.
Top
 Profile  
 
 
Posted: Sun Jul 06, 2008 1:02 pm 
Fordmods Newbie
Offline

Posts: 3

Joined: 21st Jun 2008

Ride: Falcon

Location: gold coast
QLD, Australia

Thanks for the tip, I have just tried this and still no difference. Any other ideas?
Top
 Profile  
 
 
Posted: Tue Oct 07, 2008 6:34 pm 
Fordmods Newbie
Offline

Age: 44

Posts: 3

Joined: 29th Sep 2008

Ride: Fairlane Stretch

Location: Perth, Western Australia
WA, Australia

I have a similar problem with a NL Fairlane 4.0i dual fuel I purchased recently.
There is a small white bakelite bit that sits under the stepper motor (I think thats what it is called). It has a tube that runs back into the rocker cover.
Mine was installed backwards and as such had snapped the little hose attachment part.
I visited Gas Power Australia (Coiuldnt even tell me what the part was or what it did. Very dissapointed with the service recieved) went to Steens who actually installed the system in 2000 and they said they didn't know what the broken part was and I should just remove it???
Titan Ford even argued with me that it shouldn't even be there. Until one of their older guys said something about it being a tickford fitted part to get more air in at Idle as all the Ef/EL/AU's had the same stalling problems.
Eventually a Gas place in Midland was able to tell me what it is/does and thus to fix the problem.

 

_________________

Jason Hodges
0403 307 776

www.elitetowncars.com.au

Top
 Profile  
 
 
Posted: Tue Oct 07, 2008 9:13 pm 
Parts Gopher
Offline

Age: 64

Posts: 98

Joined: 5th Nov 2004

Location: Ipswich
QLD, Australia

The part that you are refering to is to shift the PCV hose from the inlet manifold between cyl 3 and 4 to below the idle control solinoid so each cyl get an equal LPG mixture. All it does is to improve the idle.

b r Check the balance hose for leaks
Top
 Profile  
 
 
Posted: Wed Oct 08, 2008 6:40 am 
Getting Side Ways
Offline

Age: 48

Posts: 1061

Joined: 7th Sep 2007

Gallery: 3 images

Ride: BF3 Egas wag SY AWD Terry Ghia

Location: Brookfield
VIC, Australia

replace the converter with an OMVL

 

_________________

BF3 Egas XT Wagon
SY Territory Ghia AWD 6spA :))

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 11:42 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names