Fordmods Logo

Fried wires in harness - EF Tickford LPG 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Fried wires in harness - EF Tickford LPG
Posted: Sat Aug 04, 2007 8:36 pm 
Fordmods Newbie
Offline

Age: 66

Posts: 6

Joined: 4th Aug 2007

Location: Douglas Park
NSW, Australia

Need wiring diagram for EF Tickford LPG. Traced motor stoppage to lack of spark which after lots of other testing eventually let to discovery of fried auxiliary wires in the wiring harness, just short of where it enters ECU. Have Gregory's EFI and Engine Management, Vol 3 but it does not indicate all the wiring for Tickford LPG on EF.
ECU connectors do near bear signs of overheating. Wiring just short of ECU appears to have been spliced some time in the past and has shorted - unsure if the splicing is original Tickford or later mods.
What I need to know is what specific LPG related wires go to where as some have dislodged and others fused.
I have read the post in 2002 by Matti re EF/EL Tickford LPG, and although it helps with other matters, I need more specific info. I am qualified as a MVRIA LPG mechanic although I do not work in the industry - am employed in management in totally unrelated industry. Also have completed TAFE auto electrical course but electrics are still not my strong point.
This all relates to my son's vehicle, and as he is using my car at the moment, am keen to have this sorted. Thanks.
Top
 Profile  
 
 
Posted: Sat Aug 04, 2007 8:52 pm 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

Boral are the agents for Vialle, you can get the manuals for the TICKFORD equiped lpg cars at a resonable price, they include all wiring and parts and do include installation and diagnostic information.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Last edited by twase on Sun Aug 05, 2007 8:37 am, edited 1 time in total.

Top
 Profile  
 
 
Posted: Sun Aug 05, 2007 8:08 am 
Tyre Shredder
Offline
User avatar

Posts: 363

Joined: 16th Nov 2004

Power: 120 rwkw

Location: Christchurch
New Zealand

This should help you, it is for the factory (tickford) fitted EF LPG system.

http://www.fordmods.com/forums/viewtopic.php?t=47663

If you have an aftermarket Vialle system, PM me with a fax number and i can fax though a copy of the guide for aftermarket systems.

I suspect you next question will be: How I tell the difference from factory fitted and aftermarket Vialle systems?

Factory Fitted: The central locking button / switch located on the dash to the left of the steering column is used as the lpg switch and the fuel gauge does both LPG and petrol.

Aftermarket Fitted: The LPG switch/button is normally a black square with an LED that is located just above the rear demister button. Also if you look up at the dash were the AMS is mounted on the steering column there should be a small black plastic enclosure (about 100 * 70 * 20mm) that has one plug coming out of it. It is included in the LPG wiring - this is the unit that alters the spark while on LPG and is not part of the Factory Tickford set up.

The AMS is this metal unit that bolts to the steering column under the dash:
http://allyoucanupload.webshots.com/v/2 ... 2131721848
http://allyoucanupload.webshots.com/v/2 ... 9963490234
Top
 Profile  
 
 
 Post subject: LPG problems EF Tickford LPG
Posted: Sun Aug 05, 2007 9:35 am 
Fordmods Newbie
Offline

Age: 66

Posts: 6

Joined: 4th Aug 2007

Location: Douglas Park
NSW, Australia

Thanks for the info.
LPG is genuine Tickford factory LPG with one button on dash - compliance plate is also factory Tickford LPG.
Have printed all info but would really like connector configuration info for ECU - have some additional wires not mentioned in petrol only manuals. Some of these wires piggy back onto existing ECU earth leads and some of these have fried, but not at the ECU plug.
Factory workshop manual is $249 and if I have to buy it, so be it - however, would prefer not to.
Top
 Profile  
 
 
Posted: Sun Aug 05, 2007 10:29 am 
Tyre Shredder
Offline
User avatar

Posts: 363

Joined: 16th Nov 2004

Power: 120 rwkw

Location: Christchurch
New Zealand

The extra wires added to the ECU for the LPG are shown on that diagram. (ECU pin numbers are listed as well) If you rewire it as shown in the diagram it should work fine.

The diagram is out of the vialle workshop manual and it should be the same as what is in the Ford Workshop manual.
Top
 Profile  
 
 
Posted: Wed Aug 08, 2007 8:44 pm 
Fordmods Newbie
Offline

Age: 66

Posts: 6

Joined: 4th Aug 2007

Location: Douglas Park
NSW, Australia

Thought I found problem. At ECU, earth wiring from terminal 25 had been attached to earth shielding surrounding wire connected at terminal 43. Several poor connections to main earth lead to body led to overheating in joints, with accompanying melted plastic. Jumbled in the mess was the twin leads off terminal 85 for the cam angle sensor and terminal 57 for the knock sensor. The earth shielding surrounding these twin cables had also broken away. Reconnecting leads off terminals 85 and 57 was done with a Narva 2 pin plug (wires crimped then soldered) and all earths restored (soldering).
However, still no spark when cranking over. Checked 3 amp and 7.5 amp fuses at AMS - both OK. Checked cam angle sensor pulse with LED test light at terminal 85 - on cranking it is there. Checked terminals 26, 52 and 78 with LED test connected to earth. No pulse on any on cranking. Have previously checked that I had 12V+ at common terminal at coil pack. My conclusion is that computer is not open circuiting terminals 26, 52 and 78 once per revolution, at appropriate degrees BTDC, to fire each dual spark coil pack.
Want to know, please, what I need to do to run spare petrol ECU I have in this vehicle, so that I can confirm LPG ECU is the problem. If LPG ECU is subsequently found to be the problem, can you please also advise where I can get it checked. Only place I know is Automotive Computers Australia at Brookvale. Any alternatives?

Thanks.

Bob

PS. Also been previously told by another source to check that the interior light operates when door is opened. This is apparently powered by the same fuse as the smartlock system. Light operates. Have also previously checked main engine relay under coolant reservoir. Relay is OK, confirmed by fuel pump switching on for approx 3 seconds after ign is switched on.
Overall, starting to run out of ideas/options.
Top
 Profile  
 
 
Posted: Wed Aug 08, 2007 8:49 pm 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

If you have a spare petrol only ECU then you can plug it in and it should work OK in the petrol mode.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 5:49 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names