Fordmods Logo

LPG electronics playing up? 

 

Page 1 of 2 [ 30 posts ] Go to page 1, 2  Next

 
 Post subject: LPG electronics playing up?
Posted: Sat Feb 17, 2007 11:32 am 
Tyre Shredder
Offline
User avatar

Posts: 363

Joined: 16th Nov 2004

Power: 120 rwkw

Location: Christchurch
New Zealand

My EF falcon runs Vialle LPG converter and electronics (not factory fitted).

Problems:

Won't idle on LPG when cold.
Very rough idle on petrol - and has intermittent misses on petrol though out the rev range - like it's not getting fuel, even though it is running rich – sometimes has black smoke (unburnt fuel) when trying to idle.

I took it to my mechanic and he checked for vacuum leaks, changed the fuel filter and ran some injector cleaner through it but with only little improvement. He suspects the poor running on petrol is caused by the electronics for the LPG system and can't sort out the idle

I then sent the car into an LPG repairer/installer for them to have a look at, they drained the wax out of the converter, and checked everything was hooked up right, but said they said everything on the LPG side appears to be ok but couldn't do much more until the car was running properly on petrol.

After I left the LPG place the car started stalling on LPG when stopping at traffic lights, or when you are slowing down to turn in a street or round about etc. I phoned the LPG place when i got home and they said get the car running right on petrol and if it continues to stalls on LPG they will look into overhauling or replacing the LPG converter but can't do anything more in the meantime.

I've stopped using the LPG and it killing my pocket on petrol, the trip computers telling me the average fuel consumption is 35 litres to 100km.

It cost's me every time i send it into be looked at and they seem to be making no progress. Should i get an Auto sparky to check it out? What do you guys think.
Top
 Profile  
 
 
Posted: Sat Feb 17, 2007 7:55 pm 
Parts Gopher
Offline

Age: 64

Posts: 98

Joined: 5th Nov 2004

Location: Ipswich
QLD, Australia

Find another mechanic :roll: !
Top
 Profile  
 
 
Posted: Sat Feb 17, 2007 8:44 pm 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

I would first check the balance pipe is in tact and no leaks, without it, it will stall and not run well.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Sun Feb 18, 2007 9:38 pm 
Stock as a Rock
Offline
User avatar

Age: 37

Posts: 133

Joined: 6th Nov 2005

Ride: XHII ute

Location: Brisbane
QLD, Australia

Have you checked to see what codes the ecu has?

I'd probably guess the oxygen sensor?

Check the output with a multimeter after the engine is warm and see if the voltages are moving.

If it isn't running properly on either fuel, wouldn't they suggest it isnt a fuel issue?

Stationrat is right, find yourself a good mechanic. One that likes fixing cars and doesnt give up easy. This is prob going to get expensive, try and do as much as you can.
Grab a manual and check for codes first.
Top
 Profile  
 
 
Posted: Sun Feb 18, 2007 10:19 pm 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

balance pipe meh, im not running one, runs fine.

but luke111, could be on the money, check the ecu codes, would be a good place to start.

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Mon Feb 19, 2007 6:58 am 
Tyre Shredder
Offline
User avatar

Posts: 363

Joined: 16th Nov 2004

Power: 120 rwkw

Location: Christchurch
New Zealand

I found out what was causing the car to run like crap on petrol, The fuel pump was dropping dead intermittently, only for about 0.5 of a second at a time.

It got real bad on sunday and then it finally gave up the ghost, I fitted another fuel pump last night and what a diference it now runs a heck of a lot better.
Top
 Profile  
 
 
Posted: Sun Mar 04, 2007 7:43 am 
Fordmods Newbie
Offline

Age: 50

Posts: 9

Joined: 24th Jan 2006

Location: hamilton
New Zealand

hello i see in another post u have vaille comtrol box do u have a wiring diagram for it i have another set up in my car but its a basic control set up would like to wire the vialle system up to my set up any help would be good
Top
 Profile  
 
 
Posted: Mon Apr 16, 2007 12:56 pm 
Getting Side Ways
Offline

Age: 48

Posts: 535

Joined: 22nd Sep 2005

Ride: EF wagon & EF fairmont wagon & M

Location: melbourne
VIC, Australia

Oxygen sensor is almost certainly stuffed and only $50 to replace yourself. It made a huge difference to my car.
Top
 Profile  
 
 
Posted: Sat Apr 21, 2007 9:50 am 
Tyre Shredder
Offline
User avatar

Posts: 363

Joined: 16th Nov 2004

Power: 120 rwkw

Location: Christchurch
New Zealand

The car is still running like s**t. Think the 2nd fuel pump is about to drop dead and the car also stalls sometimes when you deaccelerate. Quite dangerous if you are trying to turn a corner when it stalls!!!

I think i will replace the oxygen sensor, and am looking at getting the regulator rebuilt or changing to another brand of regulator. Got prices from ford for a new Vialle regulator $3300.00 ex GST or $1300.00 ex GST for an overhaul kit.
Top
 Profile  
 
 
Posted: Sat Apr 21, 2007 12:59 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 8590

Joined: 5th Nov 2004

Gallery: 5 images

Ride: AU Fairlane 5.0, KE Laser, 01 Kw

Location: Melbourne
VIC, Australia

Piss the Vialle off mate, they're known for their problems and as you have found out, very expensive to replace/repair!

Fit an OMVL R90E to it, a lot cheaper and far more reliable.
Top
 Profile  
 
 
Posted: Sat Apr 21, 2007 1:05 pm 
Getting Side Ways
Offline
User avatar

Posts: 3363

Joined: 27th Dec 2004

Gallery: 4 images

Ride: MCMXCV Falcon

Location: G town
VIC, Australia

bottlejack15 wrote:
The car is still running like s**t. Think the 2nd fuel pump is about to drop dead and the car also stalls sometimes when you deaccelerate. Quite dangerous if you are trying to turn a corner when it stalls!!!

I think i will replace the oxygen sensor, and am looking at getting the regulator rebuilt or changing to another brand of regulator. Got prices from ford for a new Vialle regulator $3300.00 ex GST or $1300.00 ex GST for an overhaul kit.


what has the fuel pump got to do with your LPG problems?

 

_________________

Image

Top
 Profile  
 
 
Posted: Mon Apr 23, 2007 7:22 am 
Getting Side Ways
Offline
User avatar

Age: 53

Posts: 1072

Joined: 6th Jul 2006

Gallery: 13 images

Ride: BA Falcon

Power: 106 rwkw

Location: Craigmore
SA, Australia

If its running crap on both....
They both use the O2 sensor for the mixtures on both the LPG and petrol, that would be where I would start looking

 

_________________

2003 BA Falcon Egas Taxi Pack - XR Replica
Tpak MKII Build Thread

1984 ZL Fairlane
The Project

Top
 Profile  
 
 
Posted: Mon Apr 23, 2007 9:58 pm 
Oompa Loompa
Offline

Posts: 23

Joined: 14th Nov 2006

Location: Euroa
VIC, Australia

Hi all

This going to sound weird and I probably wouldn’t of believed it if it didn’t happen to me but…when I bought my EF it ran really good on gas. Then one day I noticed that the induction inlet for the air box was all smashed underneath presumably from a broken fanbelt at some stage. I tracked down a good one and then the Gas started running like crap, doing similar things to bottlejacks – engine will stall under braking etc. I never suspected it until my mechanic told me about it and I took the induction snorkel off and went for a spin around the block and sure enough it was OK on gas! My mechanic said that the air box is very restrictive at low air flows and can effect gas metering at low RPM. The holes in my induction snorkel may have been intentional. It will cost you nothing to pull yours off and give it a go. Who knows?

Scoots
Top
 Profile  
 
 
Posted: Tue Apr 24, 2007 3:34 pm 
Tyre Shredder
Offline
User avatar

Posts: 363

Joined: 16th Nov 2004

Power: 120 rwkw

Location: Christchurch
New Zealand

If i do change to an OMVL R90E do i have to change the all the LPG electrics as well???
Top
 Profile  
 
 
Posted: Tue Apr 24, 2007 3:41 pm 
Getting Side Ways
Offline

Age: 48

Posts: 535

Joined: 22nd Sep 2005

Ride: EF wagon & EF fairmont wagon & M

Location: melbourne
VIC, Australia

I don't think so as the LPG regulator is vaccuum driven so anything should work. You can get brand new OMVL for cheap from UK on Ebay. Some tickford systems use them too.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 30 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 9:07 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names