Fordmods Logo

BA XR6T Loss of power 


Page 1 of 1 [ 1 post ] 

 Post subject: BA XR6T Loss of power
Posted: Wed Jun 18, 2014 8:15 pm 
Parts Gopher

Age: 33

Posts: 80

Joined: 23rd Mar 2008

Location: Perth
WA, Australia

Hey guys,

I have had my BA XR6T for a could of weeks now, and I'm reasonably mechanically minded but this is my first turbo car and am not overly familiar with them. I just noticed on the way home from work that i seem to have lost a lot of power on boost. I take off in first and it sounds normal, turbo spooling up and then the waste gate dosing as i back off power to change gears (6 speed manual). But its raining here and i can't even get it to break traction under full boost (or even activate traction control). Certainly doesn't have the punch it used to. Something is happening, you can feel it spooling up and it certainly delivers more power than if the turbo wasn't working, but no where near what it used to.

Any ideas would be greatly appreciated, as I'm really down that this has happened just a couple of weeks after getting it. Hoping its not something major :(


Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: Google [Bot] and 8 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Fri Oct 28, 2016 5:48 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names