Fordmods Logo

Back fire at 10 Psi 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: Back fire at 10 Psi
Posted: Fri May 04, 2007 1:55 pm 
Smokin em up
Offline

Age: 30

Posts: 236

Joined: 2nd Jun 2005

Location: melbourn
VIC, Australia

when i give it to the car and when boost hits about 10Psi it starts backfireing and surging.......? but under 10 psi its ok......

 

_________________

4LTR-JET: 9.1 @150mph!!

Top
 Profile  
 
 
Posted: Fri May 04, 2007 2:09 pm 
Getting Side Ways
Offline
User avatar

Posts: 704

Joined: 19th May 2006

Gallery: 1 images

Ride: 2003 BA XT

Power: 141 rwkw

Location: Perth
WA, Australia

Well HiBoost, looks like you should run LoBoost for a while.
Top
 Profile  
 
 
Posted: Fri May 04, 2007 2:34 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 4307

Joined: 5th Nov 2004

Gallery: 9 images

Ride: EF Falcon XT-T

Location: Mornington Peninsula
VIC, Australia

mine did the same thing, as soon as the guage hit 5psi, bang.
every time.
regapped plugs and its been fine since.

my guess is its blowing out spark.

 

_________________

FALCN6 - EF GLi Turbo, 20" Rims, Air Bag Suspension, Straight LPG, 225rwkw
DTHWGN - EA GL Wagon, LTD Interior, Satin Black, 5.0, Turbo
RACER - EF Futura , 5.0, 5 Speed
PROJECT - 83 Thunderbird, Lowered, 18" Billet Wheels
DAILY - BA Fairmont Ghia 5.4 3V

Top
 Profile  
 
 
Posted: Fri May 04, 2007 2:39 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

EFFalcon wrote:
my guess is its blowing out spark.


Please explain what this is?

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Fri May 04, 2007 3:07 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 4307

Joined: 5th Nov 2004

Gallery: 9 images

Ride: EF Falcon XT-T

Location: Mornington Peninsula
VIC, Australia

exactly as it sounds, the spark produced by the spark plug is being blown out instead of igniting the mixture.
small plug gap or stronger spark will make this less likely.

 

_________________

FALCN6 - EF GLi Turbo, 20" Rims, Air Bag Suspension, Straight LPG, 225rwkw
DTHWGN - EA GL Wagon, LTD Interior, Satin Black, 5.0, Turbo
RACER - EF Futura , 5.0, 5 Speed
PROJECT - 83 Thunderbird, Lowered, 18" Billet Wheels
DAILY - BA Fairmont Ghia 5.4 3V

Top
 Profile  
 
 
Posted: Fri May 04, 2007 4:49 pm 
Getting Side Ways
Offline

Age: 31

Posts: 1679

Joined: 9th Jul 2005

Gallery: 8 images

Ride: BA XR6 TURBO

Location: Newcastle
NSW, Australia

what car mate?

if its xr6t have u gapped the plugs to .08? If not, that would probly explain it, if its a different car or u have gapped them then I am not sure

not gapping them in xr6t's usually result in pingin tho
Top
 Profile  
 
 
Posted: Fri May 04, 2007 4:52 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 4307

Joined: 5th Nov 2004

Gallery: 9 images

Ride: EF Falcon XT-T

Location: Mornington Peninsula
VIC, Australia

its an SOHC turbo.
not a BA.

 

_________________

FALCN6 - EF GLi Turbo, 20" Rims, Air Bag Suspension, Straight LPG, 225rwkw
DTHWGN - EA GL Wagon, LTD Interior, Satin Black, 5.0, Turbo
RACER - EF Futura , 5.0, 5 Speed
PROJECT - 83 Thunderbird, Lowered, 18" Billet Wheels
DAILY - BA Fairmont Ghia 5.4 3V

Top
 Profile  
 
 
Posted: Fri May 04, 2007 8:12 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 975

Joined: 26th Nov 2004

Ride: el falcon

Power: 608 rwkw

Location: Waroona
WA, Australia

its would be blowing out the spark or running lean

 

_________________

# 1997 EL Falcon GLI - 600+rwkw

# 2008 FPV FG GTE - Xa Coilovers, 20x8/ 20x10 Fairladys

Top
 Profile  
 
 
Posted: Sun May 06, 2007 12:07 pm 
Smokin em up
Offline

Age: 30

Posts: 236

Joined: 2nd Jun 2005

Location: melbourn
VIC, Australia

plugs are re-gapped to .7 and 9mm leads and std computer and fuel is not running lean... is it the mapsensor?under 10 its ok but when it hits 10psi its bang bang

 

_________________

4LTR-JET: 9.1 @150mph!!

Top
 Profile  
 
 
Posted: Sun May 06, 2007 1:33 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 4307

Joined: 5th Nov 2004

Gallery: 9 images

Ride: EF Falcon XT-T

Location: Mornington Peninsula
VIC, Australia

isnt the limitation on stock ECU/map sensor about 9-10psi?
i think the stock ecu has a cut out.

 

_________________

FALCN6 - EF GLi Turbo, 20" Rims, Air Bag Suspension, Straight LPG, 225rwkw
DTHWGN - EA GL Wagon, LTD Interior, Satin Black, 5.0, Turbo
RACER - EF Futura , 5.0, 5 Speed
PROJECT - 83 Thunderbird, Lowered, 18" Billet Wheels
DAILY - BA Fairmont Ghia 5.4 3V

Top
 Profile  
 
 
Posted: Sun May 06, 2007 3:44 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 975

Joined: 26th Nov 2004

Ride: el falcon

Power: 608 rwkw

Location: Waroona
WA, Australia

my car useto run fine on 10psi with the eec. it started to backfire around 12psi witch is were the ford map sensor stops read +ve pressure.

just get a after market ecu and all problems will end.

 

_________________

# 1997 EL Falcon GLI - 600+rwkw

# 2008 FPV FG GTE - Xa Coilovers, 20x8/ 20x10 Fairladys

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 2:09 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names