Fordmods Logo

Fordmods Advertising

De-Comp Plate 


Page 2 of 2 [ 16 posts ] Go to page Previous  1, 2

Posted: Fri Apr 11, 2008 12:57 pm 
Tyre Shredder

Age: 35

Posts: 387

Joined: 30th Nov 2007

Ride: AU111 XR6 VCT Supercharged

Location: Brisbane
QLD, Australia

MMD, yes had the head skimmed last time and it was flat. EBS41, I've read threads on your set-up and wondered why I had issues with mine! I've got standard AU head, 1.6 copper gasket, 9psi boost, water injection, run 98 octane, 250rwhp. Sorry, don't know details of ignition advance, only that motec has a 'safe' tune by a reputabe tuner in Brisbane (Masterson performance).

After all that, it appears the head gasket is fine at this stage (other than not a perfect seal...slowly uses water). Had car diagnosed today, and its the blower, not making any boost. There's no strange bearing noises (had it rebuilt 40 000km back), so I'm guessing must be a broken internal belt. Time to get it pulled apart again!



FOR SALE! - Supercharged AUIII XR6 VCT, intercooled, T5, big brakes.... details in the 'For Sale' section - ford-parts-for-sale-f17/fs-supercharged-au-xr6-vct-series-iii-intercooled-rwc-rego-t114254.html

Display posts from previous:
Sort by  
 Page 2 of 2  [ 16 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 6 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Wed Oct 26, 2016 5:06 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names