Fordmods Logo

Ford au turbo problem 

 

Page 1 of 1 [ 15 posts ] 

 
 Post subject: Ford au turbo problem
Posted: Fri May 18, 2012 1:04 pm 
Oompa Loompa
Offline

Age: 29

Posts: 24

Joined: 22nd Oct 2011

Ride: Ford AU ute

Location: Geraldton
WA, Australia

Hey
ive put a ct26 turbo ( i no to big) on a stock 4ltr . Running stock comp and stock injectors atm . it idles fine and free revs without a problem but as soon as i take it for a drive , it cuts the motor out at about 3100rpm as if it was in safety mode or if the spark in getting blown out ?? i have got the blow off valve set at soft. wat am i missing ?

Cheers
Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Fri May 18, 2012 1:07 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

When the standard map sensor sees boost pressure it cuts the engine..

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Fri May 18, 2012 1:12 pm 
Oompa Loompa
Offline

Age: 29

Posts: 24

Joined: 22nd Oct 2011

Ride: Ford AU ute

Location: Geraldton
WA, Australia

bry40l wrote:
When the standard map sensor sees boost pressure it cuts the engine..



cheers i thought it was something silly like that is the a way i can by pass that ???
Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Fri May 18, 2012 1:15 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 3355

Joined: 10th Jan 2010

Gallery: 8 images

Ride: EL XR6

Location: albion park, wollongong
NSW, Australia

How much boost u running ? Usually around 10 psi it will cut boost , since you have a au you can put a 2 bar map sensor on.
You will also need a 12:1 fmu to increase fuel pressure , it would be running lean

 

_________________

El XR6 Turbo
Dark Agents,Sunroof, bilstein shocks, 6000k HIDS, 329 mm slotted rotors, twin pot calipers , Climate Control, GarrettT04 turbo,log manifold, crow turbo cam, microtech lt10c, 42lb injectors , 044, surge tank , T56 , rebuilt bottom end , alloy plenum .

Aiming for 300 rwkw

Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Fri May 18, 2012 1:27 pm 
Oompa Loompa
Offline

Age: 29

Posts: 24

Joined: 22nd Oct 2011

Ride: Ford AU ute

Location: Geraldton
WA, Australia

ef_falcon_95 wrote:
How much boost u running ? Usually around 10 psi it will cut boost , since you have a au you can put a 2 bar map sensor on.
You will also need a 12:1 fmu to increase fuel pressure , it would be running lean


We thought we were running about 6 psi ( but yur saying it cuts out at ten so my gauge must be wrong ) and ive got my return line hald blocked off and the fuel reg is unplugged, the same why the speedway boys run there au cars to up the fuel pressure ..
Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Fri May 18, 2012 1:31 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

sounds dodgy for a road car! you cant just bolt on a turbo unplug a few things and its done,

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Fri May 18, 2012 1:39 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 3355

Joined: 10th Jan 2010

Gallery: 8 images

Ride: EL XR6

Location: albion park, wollongong
NSW, Australia

Pretty sure u still need to keep the fuel reg hooked up for the car to actually get fuel .did you plug the vacuum hose for the reg .? If not boost will be coming out of the vaccum hose . At least get a 12:1 fmu . I have one if ur interested .

 

_________________

El XR6 Turbo
Dark Agents,Sunroof, bilstein shocks, 6000k HIDS, 329 mm slotted rotors, twin pot calipers , Climate Control, GarrettT04 turbo,log manifold, crow turbo cam, microtech lt10c, 42lb injectors , 044, surge tank , T56 , rebuilt bottom end , alloy plenum .

Aiming for 300 rwkw

Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Fri May 18, 2012 1:52 pm 
Oompa Loompa
Offline

Age: 29

Posts: 24

Joined: 22nd Oct 2011

Ride: Ford AU ute

Location: Geraldton
WA, Australia

ef_falcon_95 wrote:
Pretty sure u still need to keep the fuel reg hooked up for the car to actually get fuel .did you plug the vacuum hose for the reg .? If not boost will be coming out of the vaccum hose . At least get a 12:1 fmu . I have one if ur interested .


this dodgey set up is for this weekend only causer it ment to be at a show . i got intercooler, tune etc coming but wont be here in time .. so that why we diong this..the vaqccum line tgo reg is on boost gauge . i normally have that line blocked off to fuel reg , goes harder with it unplugged.12:1 fmu what is that . ( sorry sounds like a silly question)
Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Fri May 18, 2012 1:52 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

au map sensor will cut fuel/spark around 2 psi...you need a xr6t map sensor and the ecu will need to be flash tuned. otherwise i can see big problems ahead...

also you should have vacuum line connected to the fuel reg as the fuel reg will rise fuel pressure as boost rises at a 1:1 ratio,,,
Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Fri May 18, 2012 5:05 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 1507

Joined: 14th Aug 2009

Gallery: 12 images

Ride: BA XT V8

Location: Gosnells, Perth
WA, Australia

bry40l wrote:
sounds dodgy for a road car! you cant just bolt on a turbo unplug a few things and its done,


aww i was gona do that too :roll: :lol:

 

_________________

BA XT V8. Ice Mint. 18" Speedys. XR6T LSD. Full Pacemaker twin 2 1/2inch Stainless Steel system. Custom CAI. Black XR interior with white trimming. Powerbond underdrive kit 25%.
13.65@102mph. 2800 hi-Stall.
230RWKW@5250 rpm. 625NM.

Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Fri May 18, 2012 6:12 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

1 AU Motor + Turbo + 20lb injectors + Stock ECU + Stock Fuel Reg

=



Attachment:
explosion.jpg
explosion.jpg [ 25.83 KiB | Viewed 117 times ]
Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Thu Jun 21, 2012 9:41 pm 
Getting Side Ways
Offline
User avatar

Age: 51

Posts: 918

Joined: 6th Aug 2007

Gallery: 4 images

Ride: BA XR8

Location: Kellyville
NSW, Australia

SWC wrote:
1 AU Motor + Turbo + 20lb injectors + Stock ECU + Stock Fuel Reg

=



Attachment:
explosion.jpg

double LOL.....

your username is not instilling us with the confidence, that you will take notice of anything we suggest....

Good luck to you anyway....

 

_________________

BA XR8 Boss 260
DAZFAB......Now Mobile
Mink = GAY
DAZFAB MEMBERS ,,,,DA22LE, XTT909, TERRORISTGHIA, TROYMAN, SWC, FAT245

Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Fri Jun 22, 2012 5:00 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1833

Joined: 3rd May 2007

Gallery: 8 images

Ride: AUII XR6 Uterus

Location: South Coast
NSW, Australia

Thanks for the giggle guys, I've had a pretty average day, nothing like a good laugh to make you feel better...

 

_________________

Not to get technical, but according to chemistry alcohol is a solution.

Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Mon Jan 21, 2013 1:01 am 
Oompa Loompa
Offline

Age: 31

Posts: 28

Joined: 17th Feb 2008

Ride: 92 EB S

Location: Temora
NSW, Australia

So did this guy grenade an AU motor for s**t and giggles, fix it or just give up?

 

_________________

JackoTJK

Top
 Profile  
 
 
 Post subject: Re: Ford au turbo problem
Posted: Tue Jan 22, 2013 12:26 am 
Tyre Shredder
Offline

Age: 55

Posts: 373

Joined: 9th Feb 2006

Ride: AU Wagon

Location: Newcastle
NSW, Australia

ef_falcon_95 wrote:
How much boost u running ? Usually around 10 psi it will cut boost ,

That only applies to the digital MAP sensor used in the E-series.

In series 1 AU's there doesn't seem to be any ignition cutout on boost - there wasn't on mine, I ran my Raptor kit quite happily without the MAP cheater. Series 3's definitely cut out on (around 2psi) boost, not sure about series 2.

 

_________________

AU1.5 Wagon, Raptor ProStreet kit, Pacemaker 4499's with 3" collector, 3" metal cat, 3" pipe, Pex BSO660 & BSO439, BA brakes, Sprintgas mixer LPG system, Airod variable-venturi mixer... stealth FTW Sniper tuned!

To be updated... soon!

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 15 posts ] 

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 11:59 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names