Fordmods Logo

power loss above 3000rpm 

 

Page 2 of 2 [ 21 posts ] Go to page Previous  1, 2

 
Posted: Mon Jan 29, 2007 10:25 pm 
Smokin em up
Offline

Age: 30

Posts: 236

Joined: 2nd Jun 2005

Location: melbourn
VIC, Australia

well its AU injectors with a chip to suit the boost, was working excellent till today.

 

_________________

4LTR-JET: 9.1 @150mph!!

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:34 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 975

Joined: 26th Nov 2004

Ride: el falcon

Power: 608 rwkw

Location: Waroona
WA, Australia

whateva, but i dont belive the stock au injectors will support 10psi with out 60psi+ on a 2:1 RR reg

 

_________________

# 1997 EL Falcon GLI - 600+rwkw

# 2008 FPV FG GTE - Xa Coilovers, 20x8/ 20x10 Fairladys

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:35 pm 
Fordmods Newbie
Offline

Posts: 15

Joined: 23rd Jan 2007

Location: cairns
QLD, Australia

if the car was working fine, and you havent cooked your pistons/rings due to lack of fuel thus far (check your compression) id say it was an electrical problem, like the o2 sensor or any of the other ecu imput sensors etc...

i just had my gearbox rebuilt in my AU, and we didnt reconnect the speedo... the car was way down on power due to a lack of imput into the ecu from the speed sensor. i reckon the car thought it was in neutral and so the ignition map was way retarded. reconnected the speedo and presto, car was fast again...

dont flog it till you figure it out...
Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:39 pm 
Smokin em up
Offline

Age: 30

Posts: 236

Joined: 2nd Jun 2005

Location: melbourn
VIC, Australia

pretty sure its the oxy at nights the manifold gose red hot

 

_________________

4LTR-JET: 9.1 @150mph!!

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 11:51 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

If manifod is glowing red hot then you have to much retard in your timing...
The miss at this rpm is very much like spark blowout... Close spark plug gaps to .7mm Or less ...Btw mine are at .025 thou...Unburnt fuel can cause red hot manifolds also... Leads etc MUST be in good nick.. Before you do damage atleast get an EMS Stinger and 42Lb njectors..

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
Posted: Sun Feb 04, 2007 11:41 pm 
Smokin em up
Offline

Age: 30

Posts: 236

Joined: 2nd Jun 2005

Location: melbourn
VIC, Australia

EBXR8380 wrote:
If manifod is glowing red hot then you have to much retard in your timing...
The miss at this rpm is very much like spark blowout... Close spark plug gaps to .7mm Or less ...Btw mine are at .025 thou...Unburnt fuel can cause red hot manifolds also... Leads etc MUST be in good nick.. Before you do damage atleast get an EMS Stinger and 42Lb njectors..



thanks for thatEBXr8308 i advanced it and now it it gose much more better, no more glowing manifold.

 

_________________

4LTR-JET: 9.1 @150mph!!

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 21 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 4:15 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names