Fordmods Logo

RAPTOR V on my XR8 

 

Page 3 of 4 [ 60 posts ] Go to page Previous  1, 2, 3, 4  Next

 
Posted: Thu Feb 28, 2008 11:20 pm 
Getting Side Ways
Offline

Age: 32

Posts: 942

Joined: 23rd Dec 2007

Ride: AU1 XR8

Bad news car has a cronic over heating problem and i believe it needs a new water pump so....

I have p****d the pod box off and she goes pretty hard, have started designing charger to T/B piping in 63mm dia / hoping to get some boost out of this because i have witnessed it expanding up to 5'' no joke so that cant be good.

Until i get the water pump sorted i wont be able to take it to wsid.



Brad
Top
 Profile  
 
 
Posted: Thu Mar 13, 2008 3:23 pm 
Getting Side Ways
Offline

Age: 32

Posts: 942

Joined: 23rd Dec 2007

Ride: AU1 XR8

Well i think i have issues with my maf as the car still runs the same( idle is a bit over the place) with it disconnected , car has been down on power on and off depending on the day.

Plans are to get another 55mm maf sensor from a wreck/ or from someone whos upgraded to bigger one and a 76mm maf housing from blue oval industries in the states.

this 55mm maf is also too small for boost im getting around 5psi - 6.5psi at the moment.
Top
 Profile  
 
 
Posted: Thu Mar 13, 2008 4:39 pm 
Getting Side Ways
Offline

Age: 32

Posts: 942

Joined: 23rd Dec 2007

Ride: AU1 XR8

A VID

http://www.youtube.com/watch?v=DKExsCPwsr4

For some reason youtube down grade the quality ?
Top
 Profile  
 
 
Posted: Tue Mar 18, 2008 2:49 pm 
Getting Side Ways
Offline

Age: 32

Posts: 942

Joined: 23rd Dec 2007

Ride: AU1 XR8

Okay i have swpped mafs with a mate a car runs the same but now when i rev it to 5500rpm it makes over 6 psi and stumbles like the spark might be getting blown out.

It only happens at these revs so i think i need new spark plugs one range colder ha.

I have picked up a new water pump to be installed on sunday and hopefully fix the over heating issues.

Just wondering were any of you guys out at Hungry Jacks late friday night, coz it was my brothers 21st and we were at Lone Star. Seen a few hot fords there parked together out back.

Brad
Top
 Profile  
 
 
Posted: Tue Mar 18, 2008 6:45 pm 
Getting Side Ways
Offline
User avatar

Age: 48

Posts: 7029

Joined: 18th Apr 2005

Location: Hobart
TAS, Australia

Boost, overheating & stumbling at 55rpm. only means one thing, leaning out.

 

_________________

Mind f**k!!! it works on feeble minded ignorant sheeples... there's plenty of em on this site... some are very intelligent but by god they are so thick!!!

Pakrat wrote:
You can buy them seppertly

Top
 Profile  
 
 
Posted: Tue Mar 18, 2008 7:04 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

RAPTOR_XR8 wrote:
Okay i have swpped mafs with a mate a car runs the same but now when i rev it to 5500rpm it makes over 6 psi and stumbles like the spark might be getting blown out.

It only happens at these revs so i think i need new spark plugs one range colder ha.

I have picked up a new water pump to be installed on sunday and hopefully fix the over heating issues.

Just wondering were any of you guys out at Hungry Jacks late friday night, coz it was my brothers 21st and we were at Lone Star. Seen a few hot fords there parked together out back.

Brad


yea that was us
there was about 10 fordmod cars. we were all parked next to hungry jacks in the lonestar car park..
were you with also with someone driving a station wagon..
i thought you guys might have stoped and said gday..
Top
 Profile  
 
 
Posted: Wed Mar 19, 2008 8:49 pm 
Getting Side Ways
Offline

Age: 32

Posts: 942

Joined: 23rd Dec 2007

Ride: AU1 XR8

Yeah i was going to stop but i had the honours of taking the grandmother home and by the time i got back everyone was meeting at my brothers( his fiances family) so i couldnt realy ditch them. Yeah that was my mate steve, he let me drive his wagon v8 manual and it flies but its breathless as a**.

Okay found a leaking vac hose and fixed it up now it idles at around 6-7 hundred rpm and in park or neutral at 900 rpm. Also the heater controls work now you switch to feet it works on feet.

The car is over heating even with out the blower running, it had this issue since day dot

Just curiouse that if it was leaning out at 5500rpm what would it feel like ?

it is running a walbro 255lph fuel pump, i will pull it out and see if there is anything wrong with it....

Also there isnt a way i could stuff up the wire install when i put it in right?... i will check tomorrow.

timing is still set at 30*. The power loss issue happens wether there is a blower attached or not when ever it feels like it.

Might see everyone around i live in the Liverpool area cbd.

Brad
Top
 Profile  
 
 
Posted: Wed Mar 19, 2008 10:32 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

RAPTOR_XR8 wrote:
Okay i have swpped mafs with a mate a car runs the same but now when i rev it to 5500rpm it makes over 6 psi and stumbles like the spark might be getting blown out.

It only happens at these revs so i think i need new spark plugs one range colder ha.

I have picked up a new water pump to be installed on sunday and hopefully fix the over heating issues.

Just wondering were any of you guys out at Hungry Jacks late friday night, coz it was my brothers 21st and we were at Lone Star. Seen a few hot fords there parked together out back.

Brad


Trust me!!! Go on www.corral.net and buy maf and injectors that are calibrated for forced induction...!!!
Landed here wouldn't cost more than $300.00 and your tune will be MUCH MUCH safer... Overheating ?? Could be a sign of detonation?? You don't hear mild detonation on these engines.. Blown head gaskets , overheating is a sign of bad or wrong tune... The heart of Fords tuneing is in the MAF...

Here's some links
http://www.corral.net/forums/showthread.php?t=1004229
;
http://www.corral.net/forums/showthread.php?t=1002304
;
http://www.corral.net/forums/forumdisplay.php?f=323
Try closing plug gap to .035 ?? Could be blowing spark out or mighty lean condition ??

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Last edited by EBXR8380 on Wed Mar 19, 2008 10:44 pm, edited 2 times in total.

Top
 Profile  
 
 
Posted: Wed Mar 19, 2008 10:38 pm 
Getting Side Ways
Offline

Age: 32

Posts: 942

Joined: 23rd Dec 2007

Ride: AU1 XR8

The car is over heating even with out the blower running, it had this issue since day dot.

It use to only over heat when i used the aircon and then it started over heating while just driving until i installed a 82deg thermostat but it still over heated.

it started getting worse prior to the blower being fitted, spoke to a mechanic and he seems to think it was the water pump i will know after i change it over.

Could you explain it over heating STILL with out the blower belt connected.....

As i said it has been doing this for a long time just thought it was because i didnt have a sealed box for the air filter.

I am going to gap the spark plugs(will check for over heating/lean condition)
Top
 Profile  
 
 
Posted: Wed Mar 19, 2008 10:57 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

Been all through this with my car...
Get the radiator cleaned or check what a new one costs?? There's often only $50 difference..
I'd drop your total timing back atleast 6 Degree esp while you have heating issues..
Check what there timing is on Corral ? There's a blower specific forum there...
NOT discounting water pump? But radiator would be my first thing to look at ...
Btw I have 4 core rad on mine...The std one works fine..

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
Posted: Wed Mar 19, 2008 11:14 pm 
Getting Side Ways
Offline
User avatar

Age: 48

Posts: 7029

Joined: 18th Apr 2005

Location: Hobart
TAS, Australia

Like EBXR8380 said, its either pinging from excessive heat.
replace the water pump & give it a good flush. might be worthwhile looking at replacing the rad & check your thermals. better remove the rad & check to make sure air is actually getting through the fins.

invest in an inter cooler or water/alcohol injection if space is a prob & custom tune to tie everything up. its its severe, the knock sensor can be a millisecond to late. who knows, damage may have already occurred.

 

_________________

Mind f**k!!! it works on feeble minded ignorant sheeples... there's plenty of em on this site... some are very intelligent but by god they are so thick!!!

Pakrat wrote:
You can buy them seppertly

Top
 Profile  
 
 
Posted: Thu Mar 20, 2008 9:00 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

your over heating problem could be as simple as the clutch fan not keeping up..

i know its a common thing to cause over heating issues and is normally over looked..
have you thought about using ef thermo fans???
Top
 Profile  
 
 
Posted: Thu Mar 20, 2008 8:20 pm 
Getting Side Ways
Offline

Age: 32

Posts: 942

Joined: 23rd Dec 2007

Ride: AU1 XR8

Yeah i spoke with a mechanic and he gave it a quick check over and recons the water pump fins are rooted.

The radiator is just about a year old now so brand new, after i fixed the vacuum leak i took it for a drive and the raptor is making 8.5 psi @5500 and not a hint of belt slip.

(i am pretty amazed that my bracket and belt hasnt slipped and all this with a 55mm maf).

I will retard timing and see how that goes, will set to 24* .

No intercooler is going on this car there just isnt any space and not just that but i dont want to lose boost like twr7cx has.

Brad
Top
 Profile  
 
 
Posted: Thu Mar 20, 2008 9:59 pm 
Commercial Sponsor
Offline
User avatar

Age: 49

Posts: 121

Joined: 3rd Aug 2007

Ride: Commodore VZ SV6

Location: Mackay
QLD, Australia

Thats a nice amount of boost to create excitement, fine tune it and you will be a happy man indeed. Them Raptor things will make 11psi on a 6 rib belt any day, piss easy to drive. Plenty Holdens with them making 12psi and more on a six rib -------- never slip

 

_________________

Raptor SC, blow your mind ..... not your wallet

Holden VZ SV6 Alloytec - 270rwkw (premium SC kit)

Top
 Profile  
 
 
Posted: Thu Mar 20, 2008 11:30 pm 
Getting Side Ways
Offline

Age: 32

Posts: 942

Joined: 23rd Dec 2007

Ride: AU1 XR8

I have adjusted timing to the first line over 20? 22-24*.

Over heating issues are still there only now the miss fire is happening at 4500 rpm now instead of @5500rpm ? im getting new plugs tomorrow and will gap them down.

The car has been running off power for a little while now, comes and goes maybe a TFI module? anyway i was shocked when my miss' said it went to 8.5 psi ( its breathing through a 55mm maf hole ).

Tim im absolutly wrapped in the Raptor product, at first i thought i needed a smaller pulley but the more i sat and went over ever thing one by one i started to fix issues that the car has had since i bought it and in the process it has helped in power production.

Could you believe when i first finished the install the blower it only made 3-4 psi @5500rpm ha the early days :lol: , but i will never go back to N/A it sucks the wang.

Water pump is set to go on this sunday and new plugs tomorrow stay tuned.

Brad
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 3 of 4  [ 60 posts ]  Go to page Previous  1, 2, 3, 4  Next

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 10:06 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names