Fordmods Logo

turboed ED issue... 

 

Page 1 of 2 [ 17 posts ] Go to page 1, 2  Next

 
 Post subject: turboed ED issue...
Posted: Mon Jun 01, 2009 9:08 pm 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1667

Joined: 23rd Dec 2004

Gallery: 1 images

Ride: Boosted ED XR6, EBII Mont Wgn

Power: 252 rwkw

Location: Mildura
VIC, Australia

right e o.. I'm haveing an Issue with my boosted ED XR6... it seems to have a flat spot, it happens only when the engine is warm and when it starts to spools up... I have changed the fuel filted, MAP sensor, it also has new plugs and leads.. any suggestions welcome..

 

_________________

Image
[SEXYR-6] ED XR6 T5 Turbo Build
[EBW-347] EB Wagon V8 Stroker Build
FordMods Member #1761

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Mon Jun 01, 2009 9:11 pm 
Getting Side Ways
Offline

Posts: 631

Joined: 27th Jan 2007

Ride: Supercharged BA XL ute

Location: Gordonvale
QLD, Australia

Timing not advancing up quick enough?
Too rich at that point?

 

_________________

BA XL ute.
P'maker headers',Hi flow cat,3" sports sytem,
Raptor V-clutched lightweight not intercooled,no tranny cooler,no worries.

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Mon Jun 01, 2009 9:30 pm 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1667

Joined: 23rd Dec 2004

Gallery: 1 images

Ride: Boosted ED XR6, EBII Mont Wgn

Power: 252 rwkw

Location: Mildura
VIC, Australia

badcooky wrote:
Timing not advancing up quick enough?
Too rich at that point?

yeah dont know, how would you test that???..
My base timing is set to 8deg BTDC (factory ED XR6 ECU) oh, and the plugs are set to .08mm as well..

 

_________________

Image
[SEXYR-6] ED XR6 T5 Turbo Build
[EBW-347] EB Wagon V8 Stroker Build
FordMods Member #1761

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Tue Jun 02, 2009 7:47 pm 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1667

Joined: 23rd Dec 2004

Gallery: 1 images

Ride: Boosted ED XR6, EBII Mont Wgn

Power: 252 rwkw

Location: Mildura
VIC, Australia

anyone??

 

_________________

Image
[SEXYR-6] ED XR6 T5 Turbo Build
[EBW-347] EB Wagon V8 Stroker Build
FordMods Member #1761

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Wed Jun 03, 2009 11:16 am 
Getting Side Ways
Offline

Posts: 631

Joined: 27th Jan 2007

Ride: Supercharged BA XL ute

Location: Gordonvale
QLD, Australia

Get it on the dyno bud.

 

_________________

BA XL ute.
P'maker headers',Hi flow cat,3" sports sytem,
Raptor V-clutched lightweight not intercooled,no tranny cooler,no worries.

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Wed Jun 03, 2009 11:35 am 
Getting Side Ways
Offline
User avatar

Posts: 873

Joined: 9th May 2005

Ride: BA XR6T

sexyr6 wrote:
My base timing is set to 8deg BTDC (factory ED XR6 ECU) oh, and the plugs are set to .08mm as well..

0.08mm or 0.8mm??
i run 0.8mm on my BA XR6 Turbo..
can you define the flat spot a bit more?

 

_________________

300+rwkw HeadsexTuned XR6 Turbo Ute *NOW SOLD :(*
MK Triton with 31" muddies, 2" lift and 3" turbo back exhaust etc...

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Wed Jun 03, 2009 9:57 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

The accelerator pump needs to be more aggressive due to boost its running lean..
You could try raising fuel pressure ?? But they are 1/2 a*** way..
You realy need a stand alone ECU...Check TPS voltage ?? It should be just under 1 volt.. .95v will be fine..
May have to slot TPS holes to allow adjustement..

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Wed Jun 03, 2009 10:42 pm 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1667

Joined: 23rd Dec 2004

Gallery: 1 images

Ride: Boosted ED XR6, EBII Mont Wgn

Power: 252 rwkw

Location: Mildura
VIC, Australia

Mr Man wrote:
sexyr6 wrote:
My base timing is set to 8deg BTDC (factory ED XR6 ECU) oh, and the plugs are set to .08mm as well..

0.08mm or 0.8mm??
i run 0.8mm on my BA XR6 Turbo..
can you define the flat spot a bit more?


Yeah sorry typo it's 0.8mm...
Does not start happening untill engine is warm,
and only seems to do it under boost.
its like the spark or fuel just stop, and begins to die..


EBXR8380 wrote:
The accelerator pump needs to be more aggressive due to boost its running lean..
You could try raising fuel pressure ?? But they are 1/2 a*** way..
You realy need a stand alone ECU...Check TPS voltage ?? It should be just under 1 volt.. .95v will be fine..
May have to slot TPS holes to allow adjustement..


should of said.. it's a snort stage 2 kit, fuel pump is a 040 and I have a 12:1 FMU, i've been driving this for around 5000k's, with NO issues at all before this happened...

 

_________________

Image
[SEXYR-6] ED XR6 T5 Turbo Build
[EBW-347] EB Wagon V8 Stroker Build
FordMods Member #1761

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Sat Jun 06, 2009 1:46 pm 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1667

Joined: 23rd Dec 2004

Gallery: 1 images

Ride: Boosted ED XR6, EBII Mont Wgn

Power: 252 rwkw

Location: Mildura
VIC, Australia

have just changed the coil with another one with no change..

 

_________________

Image
[SEXYR-6] ED XR6 T5 Turbo Build
[EBW-347] EB Wagon V8 Stroker Build
FordMods Member #1761

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Sat Jun 06, 2009 5:43 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

Distributor? or button? any shaft play? in the distributor that is, otherwise I KNOW your answer is yes.

Have you changed leads recently? I was going to suggest fuel filter, but you said its been changed.

This will sound lame, but reset your ECU.

Standalone ECUs are a good thing but its proven the snort stg 2 will run on a stock ecu, will just be able to tune it well with an aftermarket job.

I am going MSII with mne, but initially it will be on stock EB XR ecu..

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Sun Jun 07, 2009 12:26 am 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1667

Joined: 23rd Dec 2004

Gallery: 1 images

Ride: Boosted ED XR6, EBII Mont Wgn

Power: 252 rwkw

Location: Mildura
VIC, Australia

dc_todd wrote:
Distributor? or button? any shaft play? in the distributor that is, otherwise I KNOW your answer is yes.

Have you changed leads recently? I was going to suggest fuel filter, but you said its been changed.

This will sound lame, but reset your ECU.

Standalone ECUs are a good thing but its proven the snort stg 2 will run on a stock ecu, will just be able to tune it well with an aftermarket job.

I am going MSII with mne, but initially it will be on stock EB XR ecu..


Leads, Cap, Button, and Dizzy are all new..

I hooked up a fuel pressure guage today, I put it on the inlet side of the fuel rail and while driving it only got to 250kpa (running 250kpa std reg) on the guage, even under boost 4-5psi thats all it gets to before the flat spot appears...

To me it seems as the rising reg has s**t..

 

_________________

Image
[SEXYR-6] ED XR6 T5 Turbo Build
[EBW-347] EB Wagon V8 Stroker Build
FordMods Member #1761

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Sun Jun 07, 2009 2:40 am 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

Yes sounds like you've found the problem ??
Thought of fitting a boost retard box ??

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Sun Jun 07, 2009 2:43 am 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1667

Joined: 23rd Dec 2004

Gallery: 1 images

Ride: Boosted ED XR6, EBII Mont Wgn

Power: 252 rwkw

Location: Mildura
VIC, Australia

EBXR8380 wrote:
Thought of fitting a boost retard box ??


whats that?

 

_________________

Image
[SEXYR-6] ED XR6 T5 Turbo Build
[EBW-347] EB Wagon V8 Stroker Build
FordMods Member #1761

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Mon Jun 08, 2009 10:52 pm 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1667

Joined: 23rd Dec 2004

Gallery: 1 images

Ride: Boosted ED XR6, EBII Mont Wgn

Power: 252 rwkw

Location: Mildura
VIC, Australia

Update: checked out the FMU today, It had loose bolts so I corrected that, put it back. still no change...
I also moved the position of the fuel pressure guage, put it in between the factory reg and the FMU read 0kpa pressure, this told me the FMU is not holding any pressure, so I decided to have a look inside the FMU, I pulled it apart none of the seals or "o"ring were damaged no holes etc but I did find something after tightening the four screws inside the unit, I noticed that the rubber seal that goes between the two parts, formes a bubble, should that be there or should it be flat?? Ill try and get a photo of the bubble tomorrow.. heres a quick diagram I did..

Image

 

_________________

Image
[SEXYR-6] ED XR6 T5 Turbo Build
[EBW-347] EB Wagon V8 Stroker Build
FordMods Member #1761

Top
 Profile  
 
 
 Post subject: Re: turboed ED issue...
Posted: Tue Jun 09, 2009 5:39 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

as in the o-ring creates a convex bubble or it distorts out of shape and creates a bubble?

 

_________________

Image

I have a car.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 17 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 8:47 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names