Fordmods Logo

66 drag mustang problems 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: 66 drag mustang problems
Posted: Mon Dec 18, 2006 11:15 pm 
Parts Gopher
Offline

Age: 27

Posts: 73

Joined: 28th Sep 2006

Gallery: 5 images

Ride: 04 BA XR6

Location: Perth
WA, Australia

hey everyone,
Ive just got my drag mustang from america transported from the dock to my place this morning, and when i fired her up, alot of smoke was coming out of the sidepipes.
The engine is a big block 408 stroker if thats any good for ideas.

What could be causing this?

Also it makes a whining noise for about 5 seconds when it starts up.

I need to know what these problems are and how to fix them before i take it for a run down the strip.

according to the guy i baught it off, it's 675hp and it runs 10.2's without nos, turbo or supercharged. Is he bluffing or do those numbers sound about right

Help is much appreciated

 

_________________

HOLDEN - Holes, Oil Leaks, Dents & Engine Noise
TORANA - Tonnes Of Rust And No Acceleration

Top
 Profile  
 
 
Posted: Mon Dec 18, 2006 11:35 pm 
Getting Side Ways
Offline

Age: 37

Posts: 661

Joined: 2nd Dec 2004

Ride: AU XR8

Location: Wollongong
NSW, Australia

Tell us more about the combo.

What heads, cam, intake, compression ratio..?

EFI or Carb? Noise could be fuel pump...?

Those Mustangs are pretty light. I dont think it would need quite that much horsepower to run a 10.2...

Sounds like a weapon mate. PLEASE POST PICS!!!!!
Top
 Profile  
 
 
Posted: Mon Dec 18, 2006 11:57 pm 
Parts Gopher
Offline

Age: 27

Posts: 73

Joined: 28th Sep 2006

Gallery: 5 images

Ride: 04 BA XR6

Location: Perth
WA, Australia

oh it is, f**k it almost gave me a hard-on when i turned the key.

i dont have all the specs on it at the moment but i will post ASAP as im trying to get them off the guy in america now.

ill attach some pics of the car and of the engine/bay

It also has an original shelby bonnet scoop!!

 

 

Attachments:
inside.JPG
inside.JPG [ 54.03 KiB | Viewed 37 times ]
66 drag.JPG
66 drag.JPG [ 57.44 KiB | Viewed 39 times ]
engine.JPG
engine.JPG [ 58.99 KiB | Viewed 40 times ]

 

_________________

HOLDEN - Holes, Oil Leaks, Dents & Engine Noise
TORANA - Tonnes Of Rust And No Acceleration

Top
 Profile  
 
 
Posted: Tue Dec 19, 2006 12:05 am 
Parts Gopher
Offline

Age: 27

Posts: 73

Joined: 28th Sep 2006

Gallery: 5 images

Ride: 04 BA XR6

Location: Perth
WA, Australia

i know its got Dart Heads, holley carb, Edelbrock manifold and some other good s**t, the guy has receipts for $24k US on just the front end.

 

_________________

HOLDEN - Holes, Oil Leaks, Dents & Engine Noise
TORANA - Tonnes Of Rust And No Acceleration

Top
 Profile  
 
 
Posted: Tue Dec 19, 2006 8:53 am 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 1249

Joined: 5th Nov 2004

Ride: Falcon

Location: Melbourne
VIC, Australia

Well if the smoke continues I'd be checking the oil level every now and then and do a complressions test to see if theres any blow by, but I'd expect a bit of smoke after sitting in a containter for a few days/weeks (?). Dont know about the whining noise, but maybe localise the noise a little more, like its comming from the bellhousing, gearbox, bottomend, topend whatever just to give us a better idea, could be anything.

Nice rig, what did it cost ya, and how much did it cost to get shipped? Im sure plenty of ppl have thought about buying overseas but have been unsure of the costs so maybe you being the first gunine pig might encourage a few others.

 

_________________

I couldnt fix your brakes so I made your horn louder
Image

Top
 Profile  
 
 
Posted: Tue Dec 19, 2006 10:20 am 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

You need to be more specific. whining when? during cranking? after it fires?
BTW it ain't no big block....it's 351w stroked to 408ci.
Have you got all the specs on the engine?

Pete.
Top
 Profile  
 
 
Posted: Tue Dec 19, 2006 7:27 pm 
Parts Gopher
Offline

Age: 27

Posts: 73

Joined: 28th Sep 2006

Gallery: 5 images

Ride: 04 BA XR6

Location: Perth
WA, Australia

ive started it up and left it running for about 10 minutes, and the whining has seemed to stop, i checked this 3 or 4 times over the period of 2 days and all seems fine everytime i crank it over now. There is no smoke blowing out of the pipes anymore either.

i think it just needed to blow the cobwebs out and have a good run for awhile.

I'm going to get it dyno tested to see if the 675hp is true or not.

Well for all of you that are interested in what i payed for it and shipping costs here goes.

I payed $11,700 for the car itself via connection from my friend in america, then it cost $500 to get it transported to a dock in longbeach, California from Klamath Falls, Oregon. shipping took approximately 6 weeks. I would work on roughly $5000 per car to get it over here, give or take ( i think my quote was $5150 or something like that.)

For those of you who are interested in shipping cars pm me and i will give you full details.

 

_________________

HOLDEN - Holes, Oil Leaks, Dents & Engine Noise
TORANA - Tonnes Of Rust And No Acceleration

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 1:49 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names