Fordmods Logo

Au2 XR8 Ute D/Fuel 


Page 1 of 1 [ 1 post ] 

 Post subject: Au2 XR8 Ute D/Fuel
Posted: Wed Jan 02, 2008 9:32 pm 
Fordmods Newbie

Age: 39

Posts: 7

Joined: 19th Mar 2007

Location: Gosford
NSW, Australia

im coming to the end of the road with trying to sort out what is going on with my ute, so if anyone has some ideas pls throw them at me.
Ok here we go:
Aggressive idle for about 10 sec then sudden drop. (petrol and gas)
Surging under acceleration and whilst idling (petrol )
total lack of power on both fuels (might as well be a 2ltr)
bogging down when around 60km/h slowing down then starts to jerk around before it completely losses power then kick back up again.(petrol only)

recently replaced:
both o2 sensors
Maf sensor
fuel filter
and today another o2 sensor as ford couldnt find why passenger side Bank was constantly running rich and after having my car for over 24hrs told me it maybe a faulty o2 sensor,
but couldnt tell me why it was constantly running rich... Thanks Grawill.

ca the surging be caused by not running a balance pipe between the twin exhaust as this is what i have been told.

any help is appreciated. :?:
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: Yahoo [Bot] and 10 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Mon Oct 24, 2016 9:11 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names