Fordmods Logo

BA GT Electrical Problems 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: BA GT Electrical Problems
Posted: Tue Mar 22, 2011 1:47 pm 
Stock as a Rock
Offline

Age: 46

Posts: 118

Joined: 13th Mar 2008

Gallery: 1 images

Ride: 03 BA GT XW GT Replica

Location: Legerwood
TAS, Australia

Hi Guys,
I have a drama with my BA GT running battery flat if left for a few days. It has brand new battery . What it is doing is it will not lock doors or turn interior lights off. you press button to lock doors and it locks then unlocks and lights stay on. I cant figure out if this is a result of the battery getting to low or if this is what causes battery to go flat. I would take it to My Ford dealer but the problem seems to go away every time I think about heading in to them and then comes back. Has anyone else had this kind of trouble. Any advice or tips would be helpfull.

 

_________________

LOVE THE BLUE OVAL

Top
 Profile  
 
 
 Post subject: Re: BA GT Electrical Problems
Posted: Tue Mar 22, 2011 7:41 pm 
Getting Side Ways
Offline

Age: 48

Posts: 419

Joined: 16th Jan 2005

Ride: EF Ghia 5.0

Location: Adelaide
SA, Australia

For starters, try disconnecting the battery for 30 mins to clear the fault codes and reset everything. In the E-series, the separate Body Electronics Module can play up causing weird problems like this. Not sure how the B series cars manage those functions, but it could be the issue.

Mike

 

_________________

EF Ghia 5.0 - XR8 in a tuxedo....classy, low and loud

Bordeaux Purple, Tickford kit, slammed, 18" BA XR8's, EL Ghia chrome, full leather, Pioneer audio, C&C, ABS, LSD, Crane cam, GT40P heads, high flow cats, Genie extractors, lots of woodgrain, chrome and interior lights!

Top
 Profile  
 
 
 Post subject: Re: BA GT Electrical Problems
Posted: Tue Mar 22, 2011 7:48 pm 
Stock as a Rock
Offline

Age: 46

Posts: 118

Joined: 13th Mar 2008

Gallery: 1 images

Ride: 03 BA GT XW GT Replica

Location: Legerwood
TAS, Australia

Ok I will try that and see. Thanks mate fingers crossed it is that simple

 

_________________

LOVE THE BLUE OVAL

Top
 Profile  
 
 
 Post subject: Re: BA GT Electrical Problems
Posted: Tue Mar 22, 2011 10:48 pm 
Fordmods Newbie
Offline

Age: 42

Posts: 19

Joined: 28th Apr 2010

Ride: BA XR8 MkII

Location: langwarrin
VIC, Australia

I had a similar issue with my XR8.

I had no door locking, wipers stuck on with wash and battery running flat. Turned out to be a faulty BEM.
Top
 Profile  
 
 
 Post subject: Re: BA GT Electrical Problems
Posted: Tue Mar 22, 2011 11:46 pm 
Stock as a Rock
Offline

Age: 46

Posts: 118

Joined: 13th Mar 2008

Gallery: 1 images

Ride: 03 BA GT XW GT Replica

Location: Legerwood
TAS, Australia

I had issues with alarm going off doors not locking and interior lights staying on 6 months or so ago. After a lot of looking My ford dealer replaced BEM with new one and solved the problem. They have told me it is unlikely to be the same problem again but who knows. I simply cant afford to pay them to look at it all day. Perhaps I could change BEM again with another but last one cost $600 fitted by Ford dealer.

 

_________________

LOVE THE BLUE OVAL

Top
 Profile  
 
 
 Post subject: Re: BA GT Electrical Problems
Posted: Thu Mar 24, 2011 8:47 pm 
Stock as a Rock
Offline

Age: 46

Posts: 118

Joined: 13th Mar 2008

Gallery: 1 images

Ride: 03 BA GT XW GT Replica

Location: Legerwood
TAS, Australia

I have taken it to ford its been there 2 days. Computer says fault in left rear door. They said it was door actuator and replaced it . Rang me back late this afternoon and said problem is still there need car another day, are looking at replacing BEM under warranty but not actualy sure what it is computer still says fault in left rear door.

 

_________________

LOVE THE BLUE OVAL

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 12:49 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names