Fordmods Logo

ba xr8 engine noise 

 

Page 1 of 1 [ 13 posts ] 

 
 Post subject: ba xr8 engine noise
Posted: Thu Oct 29, 2009 5:14 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 12

Joined: 29th Oct 2009

Ride: ford falcon

Location: cranbourne
VIC, Australia

hey guys need help, i have a ba xr8 and on start up in the mornings or after work it makes a ticking noise but only goes for about 4-5 seconds then goes away completely but also it doesnt do it all the time on start up about 80 percent of the time, it only started to do this about 3-4 weeks ago now its sort pissing me off because i dont know what it is, any help would be much appreciated
Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Thu Oct 29, 2009 7:27 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 3763

Joined: 25th Nov 2004

Gallery: 6 images

Ride: EFII 5.8 NOS TerroristGhia

Power: 274 rwkw

Location: Sydney Australia
NSW, Australia

Check your oil level, could be low.
Brett

 

_________________

The Terrorist ED Retired due to RUST.
The TerrosistGhia, EF Ghia 351 EFI 5 Speed.
Millennium Falcon, Sleeper EL DOHC 6 Speed Manual EFI LPG
Member#1131
I didn't Vote for Multiculturalism, DID YOU!!!

Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Thu Oct 29, 2009 8:18 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 12

Joined: 29th Oct 2009

Ride: ford falcon

Location: cranbourne
VIC, Australia

yeah i have checked the oil level it was sweet, then i thought maybe change the oil and filter to some thing a bit fresher but still does it
Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Thu Oct 29, 2009 8:56 pm 
Stock as a Rock
Offline

Posts: 181

Joined: 7th Dec 2007

Location: sydney
NSW, Australia

Is it an early BA pre 05?

Something to do with plastic timing chain tensioner..

Later models had a metal version which doesnt do it.

Not sure if its just noise or causes damage but its not cheap to rectify..

 

_________________

Gone to a better place

Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Thu Oct 29, 2009 8:58 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 12

Joined: 29th Oct 2009

Ride: ford falcon

Location: cranbourne
VIC, Australia

yeah i have heard of that yeah mine is may 2004
Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Thu Oct 29, 2009 9:52 pm 
Stock as a Rock
Offline

Posts: 181

Joined: 7th Dec 2007

Location: sydney
NSW, Australia

Mine is a Aug 05 and does not do it.

I think somewhere in 05 ford upgraded them to metal due to the many that came back to be rectified..

Not sure if it actually harms anything or just a little noise.

 

_________________

Gone to a better place

Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Thu Oct 29, 2009 11:24 pm 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

xr6turnip wrote:
Is it an early BA pre 05?

Something to do with plastic timing chain tensioner..

Later models had a metal version which doesnt do it.

Not sure if its just noise or causes damage but its not cheap to rectify..


That'd be the reason.

AFAIK no danger, just noisy. They lose oil pressure, and are noisy until it builds back up again.

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Thu Oct 29, 2009 11:24 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

You've got plastic tensioners...Here's my thread about changing them. Doing it yourself will save lotsa money but it will take a looooong time.
http://www.perthfalcons.com.au/index.php?showtopic=6434
Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Fri Oct 30, 2009 3:14 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 12

Joined: 29th Oct 2009

Ride: ford falcon

Location: cranbourne
VIC, Australia

thank mate i thought this was going to be the case, i just rang ford for the 2 tensioners and all gaskets it came to $716.70,pretty expensive, but hey its gotta be done its starting to drive me nuts. if i left it (which i wont)will it cause any damage, by the way thanks for the info for the chage over
Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Sat Oct 31, 2009 1:17 am 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

No wuckers, buy both tensioners from the U.S. for about $120 all up or maybe get a GT500 oil pump at the same time...they're about $70. You don't need gaskets because they are re-useable(I didn't use any).
It's not likely to cause damage but it is possible if the slack in the chain causes it to get hung up, plus it can stretch the chain over time and if it does it's possible it could jump some teeth(and these are an interference engine). So the sooner you do it the sooner you'll have piece of mind.
Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Tue Nov 03, 2009 8:38 pm 
Stock as a Rock
Offline

Age: 32

Posts: 186

Joined: 5th Nov 2004

Gallery: 1 images

Ride: 1997 EL Fairmont,2008 FG G6E

Location: Melbourne
VIC, Australia

What oil filter are you useing ? If you are using a genuine ford AFL73MC this does cause engine noise at start up. If you google it u will find more info on it. People use FL820S usa motorcraft(AFL73MC) and have found this has stopped engine noise.
Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Tue Nov 03, 2009 10:55 pm 
Getting Side Ways
Offline
User avatar

Posts: 686

Joined: 11th Sep 2008

Location: Melbourne
VIC, Australia

can do the job for $500 if need?
Top
 Profile  
 
 
 Post subject: Re: ba xr8 engine noise
Posted: Fri Nov 06, 2009 2:30 pm 
Smokin em up
Offline
User avatar

Age: 31

Posts: 276

Joined: 14th Apr 2009

Gallery: 12 images

Ride: Fairmont Ghia BA 5.4L V8, AU 6

Power: 205 rwkw

Location: Perth
WA, Australia

ace87 wrote:
hey guys need help, i have a ba xr8 and on start up in the mornings or after work it makes a ticking noise but only goes for about 4-5 seconds then goes away completely but also it doesnt do it all the time on start up about 80 percent of the time, it only started to do this about 3-4 weeks ago now its sort pissing me off because i dont know what it is, any help would be much appreciated


Hey Mate,

Ive had this problem, i have managed to reduce the amount of time it ticks to about 1 second and 90% of the time it doesnt tick at all.

Basically i had the motorcraft filter on and the standard 5W-20 oil like they recommend, with this combination it would tick 9/10 times during start up for about 3-5 seconds.

So the next time i gave it a service i used slightly thicker oil - 10W-40 Castrol Magnatec. And i used the Ryco filter with an anti drainback valve. That reduced the ticking during startup to about 1 second, and 90% of the time it doesnt tick at all.

I think the problem is the recommended oil is too thin and just drains back to the sump when left for a long period of time.

 

_________________

Chaos, Panic and Disorder. My work here is finally done.
BA Fairmont Ghia 5.4L. Mods -Full Exhaust, Chipped, Custom Intake, CAI @205.4RWKW.
Stezza - Alpine Type R Splits & 6x9's, Alpine 400w RMS 4ch, 380w RMS Pioneer Mono, 2x12" Pioneer Subs and an AVH-P5950DVD Player.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 13 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 7:46 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names