Fordmods Logo

EB Idle surge after manifold swap 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: EB Idle surge after manifold swap
Posted: Tue Dec 01, 2009 4:24 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 1700

Joined: 24th Nov 2005

Gallery: 12 images

Ride: DCII LTD V8

Location: Dunedin
New Zealand

Hi guys, did the explorer conversion on a mates '92 XR8 yesterday, all went well... Although tonight, he turned it on and it will surge up and down for about 30 secs then idle fine. I plugged all the sensors back in and also set the tps to 0.97v, i marked the dizzy exactly where it was before being removed (on the rotor and also the base) so it could be put back in without having to do timing. everything is basically as it was before we did the swap.

When you unplug the ICS it dies. I'm wondering if this could be the idle screw under the TB??

 

_________________

1993 LTD V8 Oregon 5 speed "click me"

Trick Flow Heads/Cam/Intake, Crane Ignition, T5Z Trans.

Top
 Profile  
 
 
 Post subject: Re: EB Idle surge after manifold swap
Posted: Tue Dec 01, 2009 6:57 pm 
Getting Side Ways
Offline
User avatar

Posts: 1008

Joined: 21st Dec 2004

Ride: ED V8

Location: driving under the sun........now!
WA, Australia

Check your vacumn!!

 

_________________

ED XR8 Spri-mitatio-nt

Top
 Profile  
 
 
 Post subject: Re: EB Idle surge after manifold swap
Posted: Tue Dec 01, 2009 6:59 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 1700

Joined: 24th Nov 2005

Gallery: 12 images

Ride: DCII LTD V8

Location: Dunedin
New Zealand

philaddis wrote:
Check your vacumn!!


It all appears to be ok, the pcv was slightly popped out so i popped it back in but still did it. all the other vac lines appear to be ok. The gasket that goes in between upper/lower manifold was a used one, but surely it should be ok to use it again seeing it's designed for that?

 

_________________

1993 LTD V8 Oregon 5 speed "click me"

Trick Flow Heads/Cam/Intake, Crane Ignition, T5Z Trans.

Top
 Profile  
 
 
 Post subject: Re: EB Idle surge after manifold swap
Posted: Tue Dec 01, 2009 7:22 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 3763

Joined: 25th Nov 2004

Gallery: 6 images

Ride: EFII 5.8 NOS TerroristGhia

Power: 274 rwkw

Location: Sydney Australia
NSW, Australia

It will more than likely be the upper/lower gasket. Costs about 30 bucks, or get a large sheet of cardboard from the newsagent( 2-5 bucks), trace it out and make your own. Works a treat as it doesnt see excessive hear or fuel or oil.

Brett

 

_________________

The Terrorist ED Retired due to RUST.
The TerrosistGhia, EF Ghia 351 EFI 5 Speed.
Millennium Falcon, Sleeper EL DOHC 6 Speed Manual EFI LPG
Member#1131
I didn't Vote for Multiculturalism, DID YOU!!!

Top
 Profile  
 
 
 Post subject: Re: EB Idle surge after manifold swap
Posted: Tue Dec 01, 2009 7:26 pm 
Stock as a Rock
Offline

Age: 106

Posts: 188

Joined: 24th Nov 2009

Gallery: 19 images

Ride: BA Fairmont Giah v8+more

Location: albury/wodonga
NSW, Australia

check the air flow sensor in the piping (bolts to air box) make sure its pluged in and if it is give it a good claen, also check fuel regi vaccum hose, also i think there is a sensor on the inletmanifold to do with air flow or temp not quiet sure
Top
 Profile  
 
 
 Post subject: Re: EB Idle surge after manifold swap
Posted: Wed Dec 02, 2009 12:49 am 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Did you actually set your idle properly?
Top
 Profile  
 
 
 Post subject: Re: EB Idle surge after manifold swap
Posted: Wed Dec 02, 2009 5:57 am 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 1700

Joined: 24th Nov 2005

Gallery: 12 images

Ride: DCII LTD V8

Location: Dunedin
New Zealand

The tps is set at 0.97v, and when the car is idling it's at about 550-600 revs, it only surges on start up, not at any other time. Not even when at the lights, only when you turn the key on.

I unplugged the ics and it dies, was looking pretty gunky, but it's the same one that came off the old manifold, and it didn't surge when it was on the HO. It also dies when you unplug it.

Special trick to setting the base idle? I'll have a read of the sticky.

 

_________________

1993 LTD V8 Oregon 5 speed "click me"

Trick Flow Heads/Cam/Intake, Crane Ignition, T5Z Trans.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 10:26 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names