Fordmods Logo

eb xr8 Not firing then running sweet 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: eb xr8 Not firing then running sweet
Posted: Fri Oct 09, 2009 2:25 pm 
Parts Gopher
Offline

Age: 39

Posts: 94

Joined: 27th Sep 2009

Ride: eb xr8 falcon/1966 xr fairmont

Location: Elizabeth Grove
SA, Australia

Ok this is the problem
I have a eb s1 xr8 and i have replaced the following, injectors, air temp sensor, fuel pump, fuel filter, spark plugs, leads, rotor button, dizzy cap and battery.

The problem: will start and run like a kitten for 1 or 2 days then won't start at all then i disconect the battery to rest the ecu and then it will run sweet for another 1 or 2 days.
What the hell is wrong with this as it is driving me crazy. I have tried jsut about all i can with the fuel side and the spark side other than the ecu being shot.
is there any ideas guys
Top
 Profile  
 
 
 Post subject: Re: eb xr8 Not firing then running sweet
Posted: Fri Oct 09, 2009 5:40 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Need more detail on how it doesn't start please. ie is there spark and fuel when this is happening?
Top
 Profile  
 
 
 Post subject: Re: eb xr8 Not firing then running sweet
Posted: Fri Oct 09, 2009 6:33 pm 
Parts Gopher
Offline

Age: 39

Posts: 94

Joined: 27th Sep 2009

Ride: eb xr8 falcon/1966 xr fairmont

Location: Elizabeth Grove
SA, Australia

i have spark and i have loads of fuel, after trying to start it like 5 time s smells flooded
i have loads of spark and i still can't work it out slowly trying to eliminate the problem and when i fix 1 problem the car runs fine for 2 days then won't start again the only thing i can think of is the ecu
Top
 Profile  
 
 
 Post subject: Re: eb xr8 Not firing then running sweet
Posted: Sat Oct 10, 2009 4:07 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

If you have fuel and spark why do you think it's the EEC? If you can smell fuel maybe the spark is too weak? Has any of the parts you changed made it better or worse in any way?
Have you done a self test?
Top
 Profile  
 
 
 Post subject: Re: eb xr8 Not firing then running sweet
Posted: Sun Oct 11, 2009 2:28 pm 
Parts Gopher
Offline

Age: 39

Posts: 94

Joined: 27th Sep 2009

Ride: eb xr8 falcon/1966 xr fairmont

Location: Elizabeth Grove
SA, Australia

has made no difference by changing any thing, once i change something the car starts and i think it's fixed then 2 days later back to not starting. I was talking to a guy about it and he said that he had the same problems and he took it his car to a mechanic and they couldn't find anything he is a pjysics teacher and he worked it out to be the hall effect in the dizzy he got that replaced and it never happened again, so i am guessing it is in the dizzy that is making it run and then not run at all.
I haven't done a self test on the dizzy as not to sure where to start and which step to take.
Top
 Profile  
 
 
 Post subject: Re: eb xr8 Not firing then running sweet
Posted: Sun Oct 11, 2009 4:15 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Ok the EEC self test is not only for the dizzy but it can pick up PIP(HE) faults. There are lots of explanations of how to do a self test.
It could also be the TFI module. A quick way to eliminate that fault is to stick another dizzy in it.
Top
 Profile  
 
 
 Post subject: Re: eb xr8 Not firing then running sweet
Posted: Sun Oct 11, 2009 7:48 pm 
Parts Gopher
Offline

Age: 39

Posts: 94

Joined: 27th Sep 2009

Ride: eb xr8 falcon/1966 xr fairmont

Location: Elizabeth Grove
SA, Australia

i will do a tfi test and the hall effect test cause can't get hold of a dizzy just at the moment need $$$.
So if the hall effect blinks while testing it how will i know that it is faulty, does the tfi control the voltage to it. I priced a new tfi unit was $66 but i want to make sure that it is the problem before going crazy again.
Top
 Profile  
 
 
 Post subject: Re: eb xr8 Not firing then running sweet
Posted: Mon Oct 12, 2009 10:28 am 
Parts Gopher
Offline

Age: 39

Posts: 94

Joined: 27th Sep 2009

Ride: eb xr8 falcon/1966 xr fairmont

Location: Elizabeth Grove
SA, Australia

ok just done a test on the tfi unit and the readings are all over the shop. Might need a new 1 i think going by the readings it's pretty bad
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 7:37 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names