Fordmods Logo

EF 4.9 Ghia, thermo's always on?? 


Page 1 of 1 [ 2 posts ] 

 Post subject: EF 4.9 Ghia, thermo's always on??
Posted: Wed Nov 26, 2008 2:42 pm 
Getting Side Ways
User avatar

Age: 34

Posts: 613

Joined: 5th Aug 2007

Location: Ararat
VIC, Australia

Hey all, I have this issue where I think my thermos are always on (not at the capacity of the usual speed you hear when working intermittently on other cars either)

u cant hear them, but they are rotating- not due to the car being hot either as its from when you start the car.

I have always had xd,xe and EB's with clutch fans- so I'm new to electronically controlled ones! What is the best way to trouble shoot this??

Car only ever goes to nearly half heat in traffic on over 30 degree days I assume this is normal too?



EF Ghia 5L V8
BAMk2 XR8 Velocity/Cobra 19's

Posted: Fri Nov 28, 2008 12:46 am 
Stock as a Rock
User avatar

Age: 29

Posts: 150

Joined: 10th Mar 2008

Ride: ED EF and AU V8s

Location: Perth
WA, Australia

well they do have a half speed set up, the relays run the fan in serious while normal temp, but then turn them on to full when either hot or the A/C is on max.

Are they on even with just igntion on?



Too many cars atm

ED sprint
EF Fairmont V8
AU ghia V8

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: MSNbot Media and 6 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Thu Oct 27, 2016 2:32 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names