Fordmods Logo

Fordmods Advertising

EF XR8 Lights staying on 


Page 1 of 1 [ 2 posts ] 

 Post subject: EF XR8 Lights staying on
Posted: Wed Dec 17, 2008 8:38 pm 
Tyre Shredder

Posts: 330

Joined: 26th Apr 2006

Location: rockingham
WA, Australia

Didn't quite know where to put this so here it is.
I have a 95 XR8 that i have just replaced the motor in including all ancillaries and battery.
I also removed an alarm, PROPERLY.

But, As soon as the positive lead is hooked up, the Lights, High/Low and parkers are on, and they will stay on. I did not touch the harness which runs to the lights but i checked it anyway.
Any ideas where to look? I have traced everything andy checked it and it seems all right.

Cheers in advance,
Posted: Wed Dec 17, 2008 10:05 pm 
Getting Side Ways
User avatar

Age: 37

Posts: 1938

Joined: 10th Nov 2004

Gallery: 31 images


Location: THE DRUITT
NSW, Australia

Check the wiring near & connections as they connect to the lights & make sure that the wiring is sealed, I had this issue myself & I found that a wire was touching the back of the low beam globe, once I moved the wire away lights were off. From the pic posted you will see the wire hanging off the back, well the wiring that connects to that was touching the back of the globe.



IMG_5744 (Medium).JPG
IMG_5744 (Medium).JPG [ 94.45 KiB | Viewed 227 times ]




Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Thu Oct 27, 2016 10:01 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names