Fordmods Logo

ef xr8 problem 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: ef xr8 problem
Posted: Sat Feb 16, 2008 11:31 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 6

Joined: 10th Feb 2008

Gallery: 1 images

Ride: EF Xr8

Location: caloundra
QLD, Australia

hi fellas,
Got a Problem with the engine fuse, keeps blowing every time i try to start the car. been through 3 already this morning.
any suggestions would be greatly appreciated
Top
 Profile  
 
 
Posted: Sun Feb 17, 2008 2:06 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 2058

Joined: 25th May 2006

Ride: ef xr8

Power: 229 rwkw

Location: Perth
WA, Australia

Fuses are there to protect certain other parts from being fryed.

Depending on what fuse keeps blowing, I'd say have a look for exposed, cracked, poorly earthed, crossed wires.

I'd be getting an auto sparky to take a look if it doesnt jump straight away, may save alot of trouble down the track.

 

_________________

Because of Beer, Thirst is a Beautiful Thing!

'95 EF XR8 auto, Advance headers, 3" exhaust, Cobra manifold, BBK 75mm throttle body , 80MM Marauder MAF, Vortech V2 T Trim , 307 rwhp, 405 ft/lb 13.2 @ 105 MPH

Now N/A (permanent Lag) - AFR 165's, Comp XE270 cam, 1.6 RR - 269 rwhp 14.1 @ 102mph.

Top
 Profile  
 
 
Posted: Sun Feb 17, 2008 9:33 am 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

Which fuse?

When does it blow? I mean when ignition is on, or when cranking?

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
Posted: Sun Feb 17, 2008 12:56 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 6

Joined: 10th Feb 2008

Gallery: 1 images

Ride: EF Xr8

Location: caloundra
QLD, Australia

its the engine fuse beside the battery. it has blown again though. the car wont start anymore and the locks windows and stereo have stopped working, im thinking towards the smart lock. its turns over though
Top
 Profile  
 
 
Posted: Sun Feb 17, 2008 12:57 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 6

Joined: 10th Feb 2008

Gallery: 1 images

Ride: EF Xr8

Location: caloundra
QLD, Australia

I meant the fuse hasn't blown agian
Top
 Profile  
 
 
Posted: Sun Feb 17, 2008 7:39 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 6

Joined: 10th Feb 2008

Gallery: 1 images

Ride: EF Xr8

Location: caloundra
QLD, Australia

all good guys, I reset the computer and replaced the courtesy lamp fuse and the car started, still might have to get a auto elec to look at the engine fuse though. thanks for all your help
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 4:13 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names