Fordmods Logo

El v8 low coolant light 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: El v8 low coolant light
Posted: Tue Apr 07, 2009 2:23 pm 
Getting Side Ways
Offline

Age: 108

Posts: 927

Joined: 27th Sep 2007

Location: Adelaide
SA, Australia

I got an el v8, is the coolant low level warning light the one under the temp gauge?
Or is there a separate light on the cluster?

 

_________________

165 Killer Wasps all packaged in a green kmart car, almost an explorer in a way...

Top
 Profile  
 
 
 Post subject: Re: El v8 low coolant light
Posted: Tue Apr 07, 2009 2:29 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

that light under the temp is for very hot. the low coolant warning is near your odometer in the middle lower digital section of gauges. it will light up a radiator and fan symbol to the left.
Top
 Profile  
 
 
 Post subject: Re: El v8 low coolant light
Posted: Tue Apr 07, 2009 2:48 pm 
Getting Side Ways
Offline

Age: 108

Posts: 927

Joined: 27th Sep 2007

Location: Adelaide
SA, Australia

Cheers, My car is a gli and apparently they arent meant to have a low coolant sensor maybe thats why it wont work.Either that or maybe the globe is blown
Does anyone else have a v8 gli with a low coolant sensor, im just trying to see if they come with them from the factory?

 

_________________

165 Killer Wasps all packaged in a green kmart car, almost an explorer in a way...

Top
 Profile  
 
 
 Post subject: Re: El v8 low coolant light
Posted: Tue Apr 07, 2009 3:03 pm 
Smokin em up
Offline

Posts: 244

Joined: 6th Apr 2008

Location: Melbourne
VIC, Australia

I've never seen that light come on in my fairmont, which s**t me, but i think the globe is blown.
Top
 Profile  
 
 
 Post subject: Re: El v8 low coolant light
Posted: Tue Apr 07, 2009 9:45 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

have a look at your coolant tank in the engine bay, if its fitted ,it has a round threaded nut holding the sensor in the tank on the engine side. most gli's dont have them
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 6:12 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names