Fordmods Logo

EL XR8 Oil pressure problem. 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: EL XR8 Oil pressure problem.
Posted: Sat Jun 10, 2006 1:16 pm 
Stock as a Rock
Offline

Age: 43

Posts: 171

Joined: 7th Mar 2006

Location: Whyalla
SA, Australia

Here is a strange one for me. At idle and low RPM oil pressure goes up to max, but when I rev the engine it goes to normal pressure for a small period and then goes up to max again. Sometimes the pressure will fluctuate to max then normal, other times it just remains at normal pressure. Do these engines need to breathe or do I have to change my oil pump which I don't really want to do? :( :?
Top
 Profile  
 
 
Posted: Sat Jun 10, 2006 2:07 pm 
Smokin em up
Offline
User avatar

Age: 55

Posts: 219

Joined: 11th Jan 2005

Ride: Pursuit 250

Location: Katoomba
NSW, Australia

Change the sender most likely cause.
Top
 Profile  
 
 
Posted: Sat Jun 10, 2006 3:14 pm 
Stock as a Rock
Offline

Age: 43

Posts: 171

Joined: 7th Mar 2006

Location: Whyalla
SA, Australia

Sender was changed about 3 years ago when I whinged about the oil pressure when the car was under warranty. Don't mean to sound stupid but where is the sender, I'm used to working on the old Clevo's, know sweet FA about these motors.
Top
 Profile  
 
 
Posted: Sat Jun 10, 2006 3:55 pm 
Stock as a Rock
Offline
User avatar

Posts: 140

Joined: 12th May 2006

Gallery: 17 images

Location: Brisbane
QLD, Australia

The sensor is kinda located between the waterpump and the oil filter.
Top
 Profile  
 
 
Posted: Sat Jun 10, 2006 5:46 pm 
Parts Gopher
Offline

Posts: 53

Joined: 28th Dec 2004

Location: Sydney
NSW, Australia

Mine does the same thing too.
Top
 Profile  
 
 
Posted: Tue Jun 13, 2006 11:21 am 
Stock as a Rock
Offline

Age: 32

Posts: 169

Joined: 27th Jun 2005

Gallery: 6 images

Ride: EF XR8 5spd

Location: Newcastle
NSW, Australia

Mine was doing the same, was going to replace the sender, but after i did a few consecutive oil changes it doesn't do it anymore, nice clean oil maybe??

 

_________________

EF XR8 5spd: 302ci /178rwkw

Top
 Profile  
 
 
Posted: Tue Jun 13, 2006 11:32 am 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 8655

Joined: 5th Nov 2004

Gallery: 37 images

Ride: V8 EF Futura

Location: Adelaide CBD
SA, Australia

Does kinda sound like an erratic sensor reading... i'd be looking more at the wiring as opposed to the sender itself.

I seriously doubt there's anything amiss with the oil pump in that thing...

Could also double-check readings with a mech gauge?

 

_________________

I promise..... I will never die.

Fordmods Administration Group MINOR PUNKED

Top
 Profile  
 
 
Posted: Tue Jun 13, 2006 9:14 pm 
Stock as a Rock
Offline

Age: 43

Posts: 171

Joined: 7th Mar 2006

Location: Whyalla
SA, Australia

Oil was changed a couple of weeks ago. Might invest in some Bitron or Slick50.
Top
 Profile  
 
 
Posted: Wed Jun 14, 2006 3:57 pm 
Oompa Loompa
Offline
User avatar

Posts: 38

Joined: 1st May 2006

Ride: ba xr8 auto

Location: Bunbury
WA, Australia

change the sender and go the hole hog a drop some fully synthetic oil in it

 

_________________

Holy Crap what was that, that my son was BLACK LIGHTNING!!!!!!
boss 260 with BPT motorsport tune helix tower power spacer C.A.I kit 25% under drive kit cat back twin 2.5" exhaust 250-260kw at the rears

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 3:30 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names