Fordmods Logo

EL XR8 running rough.... 

 

Page 2 of 2 [ 24 posts ] Go to page Previous  1, 2

 
Posted: Fri Feb 16, 2007 7:39 pm 
Getting Side Ways
Offline

Age: 48

Posts: 419

Joined: 16th Jan 2005

Ride: EF Ghia 5.0

Location: Adelaide
SA, Australia

Have your fuel pressure AND flow rate checked properly. I had similar probs a while back. After checking everything, it was the small connector between fuel pump and outlet pipe to the motor (in the fuel tank). Cost? $2.70 and 15 minutes to replace.

Although lately, the power loss and rough idle are happening again.... :?

Mike

5 x GENUINE FTR's for sale!

 

_________________

EF Ghia 5.0 - XR8 in a tuxedo....classy, low and loud

Bordeaux Purple, Tickford kit, slammed, 18" BA XR8's, EL Ghia chrome, full leather, Pioneer audio, C&C, ABS, LSD, Crane cam, GT40P heads, high flow cats, Genie extractors, lots of woodgrain, chrome and interior lights!

Top
 Profile  
 
 
Posted: Fri Feb 16, 2007 9:18 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 2351

Joined: 11th Nov 2004

Gallery: 30 images

Ride: Blown XR8

Location: Melbourne
VIC, Australia

If anyone wants, i have a MAF from my EL XR8, that i no longer need, if they want to test and see if that works, as it was working fine on my car when i took it off.
Top
 Profile  
 
 
Posted: Fri Feb 16, 2007 10:55 pm 
Parts Gopher
Offline
User avatar

Age: 51

Posts: 93

Joined: 19th Nov 2004

Gallery: 2 images

Ride: EL V8 Ghia

Location: Sydney
NSW, Australia

before buying a new MAF try cleaning it first to see if it makes a difference. check this sites on how to clean a MAF. http://www.fordscorpio.co.uk/cleanmaf.htm
http://www.berrysweb.com/clean_your_maf.htm
http://www.muscularmustangs.com/maf.php

 

_________________

can't aFORD lately

Top
 Profile  
 
 
Posted: Sat Feb 17, 2007 1:17 am 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 3763

Joined: 25th Nov 2004

Gallery: 6 images

Ride: EFII 5.8 NOS TerroristGhia

Power: 274 rwkw

Location: Sydney Australia
NSW, Australia

I am in Sydney and have a stock MAF for those in Sydney. It should help if that is the cause.
Was the cause on my doing very similar things when i first got it. Doesnt have a MAF anymore so i got one if anyone wants it
Brett

 

_________________

The Terrorist ED Retired due to RUST.
The TerrosistGhia, EF Ghia 351 EFI 5 Speed.
Millennium Falcon, Sleeper EL DOHC 6 Speed Manual EFI LPG
Member#1131
I didn't Vote for Multiculturalism, DID YOU!!!

Top
 Profile  
 
 
Posted: Sat Feb 17, 2007 2:05 pm 
Getting Side Ways
Offline

Age: 35

Posts: 516

Joined: 3rd Dec 2004

Ride: SZ Titanium & ZG Fairlane

Location: Roxby Downs
SA, Australia

I might give the clean a go with my MAF. I found a shagged battery terminal last weekend and replaced that and it seemed to be fine. Today I noticed that it did run ok until I pulled up in the driveway and it started to idle rough again. The annoying thing with my car is that it is intermittent. I will start the car and it will rev up and down and stall and blow black smoke and have a fuel smell. Then come back half an hour later and try it and it will run fine as if nothing is wrong with it. Could that still be the MAF being so intermittent?

 

_________________

Image
F6 Rspec #139 - Stock Car Racing

Top
 Profile  
 
 
Posted: Tue Feb 20, 2007 5:28 pm 
Getting Side Ways
Offline

Posts: 617

Joined: 11th Nov 2004

Gallery: 5 images

Ride: AU III XR8 347ci

Location: Canberra
ACT, Australia

TerroristGHIA wrote:
I am in Sydney and have a stock MAF for those in Sydney. It should help if that is the cause.
Was the cause on my doing very similar things when i first got it. Doesnt have a MAF anymore so i got one if anyone wants it
Brett


Hey mate.

I might take you up on that offer, just to see if it actually is the MAF!

Im actually in Canberra at the moment, as i work here, although spend most of my time in Sydney.

I'll be back up in Sydney sometime from this Thursday or Friday onwards, for a few weeks.

Where abouts are you located mate?

Much appreciated!
Top
 Profile  
 
 
Posted: Thu Feb 22, 2007 12:25 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

I don't know if this is any help... but one day my car was running so bad I thought the motor was cactus. I was driving normal and it started experiencing problems like you mentioned but at an extreme level. It cut out as I was pulling up on the side of the road and wouldn't run at idle when I started it up again.

After much pushing, pulling and wobbling of anything I could touch in the engine bay without burning myself it turned out to be that big loop thing just above the arrow in your pic. It was only just hanging on to the inlet pipe or whatever it is called but not sealed properly. I pushed it back in, tightened it up and she ran sweet again.

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
Posted: Thu Feb 22, 2007 7:46 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Another thing... there was mention of driving it cold. Always warm your car up before driving. Just til the temp needle moves a bit at least. You'll increase the life of your engine by doing so.

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
Posted: Thu Feb 22, 2007 10:18 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 2058

Joined: 25th May 2006

Ride: ef xr8

Power: 229 rwkw

Location: Perth
WA, Australia

My xr8 was idling really rough a couple of months before i sold it. It might just be worth checking.

Take of the engine cover and where the upper intake manifold is there is a hose (vacuum) that runs directly under it . It gets a fair bit of heat exposure and can get brittle and crack. Enough to make it idle pretty rough.

Just sounds so similar to what i had.

 

_________________

Because of Beer, Thirst is a Beautiful Thing!

'95 EF XR8 auto, Advance headers, 3" exhaust, Cobra manifold, BBK 75mm throttle body , 80MM Marauder MAF, Vortech V2 T Trim , 307 rwhp, 405 ft/lb 13.2 @ 105 MPH

Now N/A (permanent Lag) - AFR 165's, Comp XE270 cam, 1.6 RR - 269 rwhp 14.1 @ 102mph.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 24 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 4:06 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names