Fordmods Logo

Flat spotting issues-PLEASE HELP 


Page 1 of 1 [ 2 posts ] 

 Post subject: Flat spotting issues-PLEASE HELP
Posted: Tue Sep 25, 2007 9:20 pm 
Stock as a Rock

Age: 31

Posts: 107

Joined: 7th Dec 2004

Gallery: 1 images

Location: Melbourne
VIC, Australia

hey all. i have an AUII fairmont ghia v8 5ltr

Now my car is flat spotting in 1st and 2nd gears. i used to put regular unleaded in the car and it flat spotted heaps now i put premium and i flat spots lightly but still does it. the problem i have with this is that is even causes my tacho to jump according to the flat spots.


can someone, ANYONE help me with my getting mods done to it and this flat spotting issue is slowing me down.




JETEA - ROARN8 - AUII Fairmont Ghia, V8, leather, sunroof, SAT NAV etc. 175KW

Posted: Tue Sep 25, 2007 10:00 pm 
Getting Side Ways
User avatar

Age: 29

Posts: 2116

Joined: 13th Aug 2005

Gallery: 15 images

Ride: 1999 XHII XR8, 2002 AU Fairmont

Power: 236 rwkw

Location: Perth
WA, Australia

First thing everyones gonna ask, and we say it almost every second day :lol: is, have you checked and cleaned the MAF sensor?



1999 XHII Falcon XR8 Ute 5.0L, TKO600 5spd, KB 2.1L Blower, 6.5psi, 12.2@113mph!!

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sun Oct 23, 2016 5:47 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names