Fordmods Logo

Is ford full of crap?... 

 

Page 2 of 2 [ 18 posts ] Go to page Previous  1, 2

 
 Post subject: Re: Is ford full of crap?...
Posted: Fri Oct 09, 2009 11:13 pm 
Getting Side Ways
Offline

Posts: 790

Joined: 18th Mar 2005

Gallery: 4 images

Location: Adelaide
SA, Australia

How about this one? In the late 70's mate of my dad bought a brand new Cobra XC coupe; had it 3 days and it started ticking away like it had a dead lifter.. so, back to rebel Ford and they said yep, no worries, we'll fix it, anyway they had it for like 3 months... me and the mate are coming home from work, see a nice LTD in the yard we stop to check out... so here we are, in overalls at the back of the yard, and we hear this tickticktick coming thru the yard...past us goes a very dirty cobra with oil all over the back of it - this is because the boot, which is open, has 3 engines in it. 2 apprentices driving it - yep, you guessed it, my mate's dad's car is being used to haul engine blocks around the place...

 

_________________

351 4V XB Coupe running LPG

Top
 Profile  
 
 
 Post subject: Re: Is ford full of crap?...
Posted: Sat Oct 10, 2009 11:33 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

Simla issue on another brand..

I have a 07 WRX with 1200 klrs on it..Bought it new and has had many flat batteries..
It goes flat in 10 days..
I was told by Subaru to drive it more often !!!
I NEVER read anything that driving a certain klrs was a prerequisite to keeping battery charged!!
The security system has been changed a little to stop battery usage while garaged..
Sheesh !! I couldn't leave it at airport while overseas!!

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
 Post subject: Re: Is ford full of crap?...
Posted: Sun Oct 11, 2009 12:09 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

EBXR8380 wrote:
Simla issue on another brand..

I have a 07 WRX with 1200 klrs on it..Bought it new and has had many flat batteries..
It goes flat in 10 days..
I was told by Subaru to drive it more often !!!
I NEVER read anything that driving a certain klrs was a prerequisite to keeping battery charged!!
The security system has been changed a little to stop battery usage while garaged..
Sheesh !! I couldn't leave it at airport while overseas!!


we had similar issues with the evo 9 lancers when i worked at mitsubishi..
within 2 or 3 weeks the batteries would go flat..
to make matters worse they have the satalite tracking imobilisers and once the battery goes flat it imobilises the car which then needs a whole heap of codes to enable a reset to start the bloody things..
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 18 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: Yahoo [Bot] and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 11:42 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names