Fordmods Logo

Low coolant sensor not working? 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Low coolant sensor not working?
Posted: Sun Apr 26, 2009 1:29 pm 
Getting Side Ways
Offline

Age: 108

Posts: 927

Joined: 27th Sep 2007

Location: Adelaide
SA, Australia

Got a new low coolant sensor for my el and it doesnt work, theres power at the plug and when you unplug it the light on the dash flashes but when the coolant drops below the low level it doesnt flash at all?
Any ideas?

 

_________________

165 Killer Wasps all packaged in a green kmart car, almost an explorer in a way...

Top
 Profile  
 
 
 Post subject: Re: Low coolant sensor not working?
Posted: Sun Apr 26, 2009 3:20 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 4326

Joined: 30th Oct 2006

Gallery: 18 images

Ride: Envi EF

Location: Grafton
NSW, Australia

New sensor..... they do fk up a fair bit, I've replaced two in 2 years.

 

_________________

>>>EF Futura T build<<<

Top
 Profile  
 
 
 Post subject: Re: Low coolant sensor not working?
Posted: Sun Apr 26, 2009 3:50 pm 
Getting Side Ways
Offline

Age: 108

Posts: 927

Joined: 27th Sep 2007

Location: Adelaide
SA, Australia

It is brand new, thought about getting another just to be sure.
The chances of gettting a dead unit when it is brand new are pretty small but still quite possible.

 

_________________

165 Killer Wasps all packaged in a green kmart car, almost an explorer in a way...

Top
 Profile  
 
 
 Post subject: Re: Low coolant sensor not working?
Posted: Sun Apr 26, 2009 3:55 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 4326

Joined: 30th Oct 2006

Gallery: 18 images

Ride: Envi EF

Location: Grafton
NSW, Australia

Ask for a replacement if its dead out of the box.

 

_________________

>>>EF Futura T build<<<

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 8:31 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names