Fordmods Logo

MAF Clean 

 

Page 2 of 2 [ 20 posts ] Go to page Previous  1, 2

 
 Post subject: Re: MAF Clean
Posted: Wed Nov 11, 2009 11:52 pm 
Getting Side Ways
Offline

Age: 48

Posts: 419

Joined: 16th Jan 2005

Ride: EF Ghia 5.0

Location: Adelaide
SA, Australia

Probably better to squirt in there while the engine isn't running and the wires aren't hot, right?

Mike

 

_________________

EF Ghia 5.0 - XR8 in a tuxedo....classy, low and loud

Bordeaux Purple, Tickford kit, slammed, 18" BA XR8's, EL Ghia chrome, full leather, Pioneer audio, C&C, ABS, LSD, Crane cam, GT40P heads, high flow cats, Genie extractors, lots of woodgrain, chrome and interior lights!

Top
 Profile  
 
 
 Post subject: Re: MAF Clean
Posted: Thu Nov 12, 2009 12:10 am 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Yep.
Top
 Profile  
 
 
 Post subject: Re: MAF Clean
Posted: Mon Nov 30, 2009 12:42 am 
Fordmods Newbie
Offline

Age: 32

Posts: 16

Joined: 8th May 2009

Ride: AU II XR8 UTE Pursuit 200

Location: Browns Plains
QLD, Australia

alright guys mines been running like a pig thught it was MAF removed it and car still ran like s**t. What else could it be?
Top
 Profile  
 
 
 Post subject: Re: MAF Clean
Posted: Mon Nov 30, 2009 1:11 am 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

If you removed the MAF it will run like s**t. There are a number of reasons why it might run like s**t....you'll need to supply a lot more information.
Top
 Profile  
 
 
 Post subject: Re: MAF Clean
Posted: Mon Nov 30, 2009 5:17 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 1700

Joined: 24th Nov 2005

Gallery: 12 images

Ride: DCII LTD V8

Location: Dunedin
New Zealand

sd1800 wrote:
Waggin wrote:
Yeah, I cleaned mine by reming the electronics from the body. I was reading that both WD40 and cotton buds are both big no-no's for cleaning it though, hence buying the specialised electronic contact cleaner. It's a whopping $10 from Jaycar :)


How do you remove the electronics from the TB? I tried last night and theres two screws holding it together. One is a Torx screw but the other doesn't seem to have head on it. I tried popping it off but didn't seem to work. Such a simple question but had me stumped for 20 minutes before i gave up.

BTW sorry about the thread mine. Was the most relevant when i used the search function.


The head will have a grey hard powdery cap on it, just scrape it off to reveal the torx head.

 

_________________

1993 LTD V8 Oregon 5 speed "click me"

Trick Flow Heads/Cam/Intake, Crane Ignition, T5Z Trans.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 20 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 8:53 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names