Fordmods Logo

missing windsor! 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: missing windsor!
Posted: Fri May 09, 2008 2:17 am 
Getting Side Ways
Offline
User avatar

Posts: 1008

Joined: 21st Dec 2004

Ride: ED V8

Location: driving under the sun........now!
WA, Australia

Standard EL windsor has developed a miss under heavy acceleration.

Misses a couple of times around 4-4,500 rpm and then pulls ok again....

suggestions?

Haven't touched a thing yet, but am thinking plugs and leads would be first thing to check?

Any other thoughts people??

MAF, dizzy, coil etc?

 

_________________

ED XR8 Spri-mitatio-nt

Top
 Profile  
 
 
Posted: Fri May 09, 2008 6:33 am 
Fordmods Newbie
Offline

Age: 41

Posts: 17

Joined: 15th Oct 2006

Gallery: 1 images

Ride: ED V8 wagon

Location: melbourne
VIC, Australia

try the MAF sensor i took mine out (2 torx head screws) and just sprayed it CRC 5.56 let it dry and put it back in and all was good again mine also seemed a bit slugish to take off aswell

 

_________________

Harden the F*&^ up

Top
 Profile  
 
 
Posted: Fri May 09, 2008 9:24 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

I'd definately check the plugs and leads first off. MAF is an easy check as well. It can't hurt to give it a clean

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
Posted: Fri May 09, 2008 3:49 pm 
Fordmods Newbie
Offline
User avatar

Age: 31

Posts: 11

Joined: 10th May 2007

Gallery: 4 images

Ride: EF Falcon XR8

Location: Melbourne
VIC, Australia

Might not hurt to check injectors

 

_________________

BPT Race Series Underdrives, Gennie Extractors, Single 3" Exhaust System, Exeedy Heavy Duty Clutch, DBA Slotted Rotors, Ferodo Formula Brake Pads, Quadrent/Bilstein Height Adjustable Front Coilovers, Matched Bilstein Shocks/Quadrent Springs, Nolathane Bushes, Dunlop Formula R D01J Tyres

Top
 Profile  
 
 
Posted: Fri May 09, 2008 3:55 pm 
Getting Side Ways
Offline

Posts: 6913

Joined: 6th Nov 2004

Gallery: 4 images

Ride: BF XR6, BF XT Wagon

Power: 197 rwkw

Location: Perth
WA, Australia

Leads. I had the same problem on my car.

Heavy acceleration misses under normal/light acceleration all is fine.

Might find one of the leads may be hitting the exhaust manifold. Thats what mine was.

 

_________________

EL XR8
Timmeh banned himself from being a moderator.

Top
 Profile  
 
 
Posted: Fri May 09, 2008 4:21 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

I had the exact same problem too

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: Yahoo [Bot] and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 12:54 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names