Fordmods Logo

My EL XR8 problem ??? 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: My EL XR8 problem ???
Posted: Thu Nov 26, 2009 3:54 pm 
Stock as a Rock
Offline

Age: 31

Posts: 156

Joined: 16th Oct 2009

Gallery: 1 images

Ride: 98 EL xr8

Location: Brisbane
QLD, Australia

hay all

my car when trying to start kicks over revs up to about 1500rpm then drops right off and stalls.. or if i am in the car when its starting to drop the revs i tap the accelerator and it seems to hold the idle fine... when its idling it seems to have a slight Miss then it will run a bit rough then even out then have a miss again....

NOW this is what i have done to the car...

thermo housing had a leak.. so bought new housing gasket and thermo..
2 days later radiator cracked so bought a new radiator...
2 days later water pumped fuked up... so bought a new one and fitted it...

some ppl say it could be a blown head gasket but i am not using coolant i drove it to sydney no problem at all doesn't over heat doesn't have milky colored oil......

this miss will happen when cold or even hot...
i have got new plugs.rotor,dissy,coil, and 9mm leads... cleaned throttle body.
i thought it could be a sensor but no fault codes....

at idle at sets of lights its sitting on about 500rpm...

when i give it a boot or decided to loose some tread it hammers just idle its a problem..

please HELP ME :( :?

 

_________________

NO longer own a car... but my work ute is a falcon..

current rides
Harley Fatboy 05
Custom shadow 07
Sportster 02

Top
 Profile  
 
 
 Post subject: Re: My EL XR8 problem ???
Posted: Thu Nov 26, 2009 5:02 pm 
Oompa Loompa
Offline

Posts: 24

Joined: 2nd Sep 2006

Location: Melbourne
VIC, Australia

You sure it's not something simple like the idle speed control valve?
Top
 Profile  
 
 
 Post subject: Re: My EL XR8 problem ???
Posted: Thu Nov 26, 2009 5:11 pm 
Stock as a Rock
Offline

Age: 31

Posts: 156

Joined: 16th Oct 2009

Gallery: 1 images

Ride: 98 EL xr8

Location: Brisbane
QLD, Australia

umm i am new to ford and new to mechanics.. where would i be looking for that ????

 

_________________

NO longer own a car... but my work ute is a falcon..

current rides
Harley Fatboy 05
Custom shadow 07
Sportster 02

Top
 Profile  
 
 
 Post subject: Re: My EL XR8 problem ???
Posted: Thu Nov 26, 2009 10:26 pm 
Getting Side Ways
Offline
User avatar

Posts: 6432

Joined: 5th Nov 2004

Gallery: 6 images

I would suspect the harmonic balancer.

 

_________________

5.6L of carbon footprint.

Top
 Profile  
 
 
 Post subject: Re: My EL XR8 problem ???
Posted: Sat Nov 28, 2009 4:43 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Has anyone touched your base idle? Sounds to me like it would be worth checking. Read this thread and flollow it carefully to check the base idle. ford-v8-f2/adjusting-base-idle-and-setting-t-p-s-voltage-t56990.html

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
 Post subject: Re: My EL XR8 problem ???
Posted: Tue Dec 15, 2009 12:53 pm 
Stock as a Rock
Offline

Age: 31

Posts: 156

Joined: 16th Oct 2009

Gallery: 1 images

Ride: 98 EL xr8

Location: Brisbane
QLD, Australia

yeh i have touched it at all..

thanks for the link i will try that this arvo :D

 

_________________

NO longer own a car... but my work ute is a falcon..

current rides
Harley Fatboy 05
Custom shadow 07
Sportster 02

Top
 Profile  
 
 
 Post subject: Re: My EL XR8 problem ???
Posted: Wed Dec 16, 2009 11:52 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Are all your vac lines intact?
Top
 Profile  
 
 
 Post subject: Re: My EL XR8 problem ???
Posted: Thu Dec 17, 2009 7:55 am 
Stock as a Rock
Offline

Age: 31

Posts: 156

Joined: 16th Oct 2009

Gallery: 1 images

Ride: 98 EL xr8

Location: Brisbane
QLD, Australia

no i didnt touch the vacc lines... i have now just checked and all seems to be ok..

clean the air intake sensor (one after airbox) seems to have brought the idle up a bit better not much... still powers ok doent miss while on the accelerator.. only coming to a stop and at idle.. feels like it may stall..

 

_________________

NO longer own a car... but my work ute is a falcon..

current rides
Harley Fatboy 05
Custom shadow 07
Sportster 02

Top
 Profile  
 
 
 Post subject: Re: My EL XR8 problem ???
Posted: Thu Dec 17, 2009 7:16 pm 
Tyre Shredder
Offline

Posts: 341

Joined: 5th Dec 2009

Location: Perth
WA, Australia

Bump up your idle, theres a thread that tells you how on here.
Clean the isc too.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 11:52 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names