Fordmods Logo

NC 5.0 running temp? 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: NC 5.0 running temp?
Posted: Wed Jan 16, 2008 10:49 pm 
Getting Side Ways
Offline

Age: 41

Posts: 4629

Joined: 23rd Nov 2006

Gallery: 4 images

Ride: 5.0 AU's and 5.0 Maverick

Power: 139 rwkw

Location: Sydney West
NSW, Australia

Hi all
Im hoping someone can give me the standard running temp for a 5.0 out of an EB-NC in degrees F?
I am setting up my thermos and stuff after doing my conversion and the truck does not seem to be warming up properly and is not temp stable. It has not over heated or anything.
I currently have the fans set to switch on at 178 degrees F according to my autometer. Whe trtavelling the truck sits at just below 150 most of the time. Maybe this could help my poor fuel economy.
I am off to get a new thermostat tomorrow after work.
Any ideas peoples on what the standard running temp should be?
Cheers

 

_________________

xr6turnip wrote:
More people paid for a ride in a VT commodore then an AU Falcon so the VT is superior.
Based on that fact my Mum is the best around!

Top
 Profile  
 
 
Posted: Fri Jan 18, 2008 9:55 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Std t-stat is about 90C I believe. So you'd be running at around 200F.
Running as cold as you are will definitely increase fuel use. Plus ring wear goes up exponentially below 82C.
Top
 Profile  
 
 
Posted: Sun Jan 20, 2008 11:42 pm 
Tyre Shredder
Offline

Age: 28

Posts: 391

Joined: 26th Mar 2007

Ride: eb

Location: frankston
VIC, Australia

dont know how many c but my 5lt sits near the bottom line is that to low
Top
 Profile  
 
 
Posted: Sun Jan 20, 2008 11:48 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

falcon gl wrote:
dont know how many c but my 5lt sits near the bottom line is that to low


If the gauge and sender are ok it probably is too low.
Point a laser thermometer at the engine and confirm the actual temp it's running at.
Top
 Profile  
 
 
Posted: Mon Jan 21, 2008 12:05 am 
Getting Side Ways
Offline

Age: 41

Posts: 4629

Joined: 23rd Nov 2006

Gallery: 4 images

Ride: 5.0 AU's and 5.0 Maverick

Power: 139 rwkw

Location: Sydney West
NSW, Australia

Well I found my thermostat was stuck open so I went and bought a new one. It is fully open at 82C or 180F.
Have the fans now coming in at 190F and all seems to be sweet. It sits solid at 180 and when the fans come in they are only going for about 20seconds.
Pretty happy here.

 

_________________

xr6turnip wrote:
More people paid for a ride in a VT commodore then an AU Falcon so the VT is superior.
Based on that fact my Mum is the best around!

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 6:48 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names