Fordmods Logo

New Leads 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: New Leads
Posted: Sat Jun 18, 2005 9:40 pm 
Stock as a Rock
Offline
User avatar

Age: 46

Posts: 186

Joined: 16th Jun 2005

Ride: XR8 Tickford AU

Location: Perth / Fremantle W.A
WA, Australia

Greetings out to all :wink:
Just want to give a plug out to A1 High Performance in Myaree W.A. have had a few idle drama's with my AUXR8 , went over to see Ben , and left with a new set of MSD 8.5mm leads and a set of NGK IRIDIUM plugs , installed them and whalla problems solved :D
15 mins of wisdom beat Titan Fords computers and "Trained Tech's"


next is cold air induction from Ben ....$80 as aposed to $250 from D&T Performance :shock: :shock:
Top
 Profile  
 
 
Posted: Sun Jun 19, 2005 2:50 am 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

yer heard good things about A1 :)

mmm ford kinda sux somtimes with fixing thier own cars

strange that the aftermarket industry knows more about fords cars than ford themsleves......

 

_________________

RIP SCOTT

Top
 Profile  
 
 
Posted: Sun Jun 19, 2005 3:13 am 
Getting Side Ways
Offline

Age: 36

Posts: 7287

Joined: 5th Nov 2004

Gallery: 12 images

Ride: 1994 ED XR8 Sprint

Location: Somewhere in
QLD, Australia

Disco Frank wrote:
strange that the aftermarket industry knows more about fords cars than ford themsleves......

sounds about f**k normal to me.....

 

_________________

Banned

Top
 Profile  
 
 
Posted: Sun Jun 19, 2005 2:21 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

Interceptor wrote:
Disco Frank wrote:
strange that the aftermarket industry knows more about fords cars than ford themsleves......

sounds about f**k normal to me.....


mmm now i think about it
your right LOL

 

_________________

RIP SCOTT

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 2:44 pm 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 8655

Joined: 5th Nov 2004

Gallery: 37 images

Ride: V8 EF Futura

Location: Adelaide CBD
SA, Australia

Good stuff sith. Love the avatar too 8-)

 

_________________

I promise..... I will never die.

Fordmods Administration Group MINOR PUNKED

Top
 Profile  
 
 
Posted: Tue Jun 21, 2005 12:53 am 
Fordmods Newbie
Offline
User avatar

Age: 52

Posts: 13

Joined: 14th Jun 2005

Gallery: 3 images

Location: perth
WA, Australia

YES A1 ARE THE BEST <lynford charged $630 to fix my missing prob with the motor and when i left it was the same.Took it to A1 and between lyon and ben the car was fixed in 30 min .Took 8 weeks to get my money back from ford,when will they get good technicians?.Maybe when they pay them enough?.A1 :mrgreen:

 

_________________

fpv/tickford owners club of w.a (inc) Au220
14.92@101.72 1/4mile

Top
 Profile  
 
 
Posted: Tue Jun 21, 2005 12:24 pm 
Tyre Shredder
Offline
User avatar

Age: 32

Posts: 320

Joined: 19th Nov 2004

Gallery: 3 images

Ride: AU-XR8

Location: Sth Syd
NSW, Australia

The second my warranty runs out, Ford will never see me or my car in the service department again!

 

_________________

She'd be a lot more modded if I didn't have to keep wasting cash on repairs.

Top
 Profile  
 
 
Posted: Fri Jul 29, 2005 9:38 pm 
Getting Side Ways
Offline

Posts: 6913

Joined: 6th Nov 2004

Gallery: 4 images

Ride: BF XR6, BF XT Wagon

Power: 197 rwkw

Location: Perth
WA, Australia

Ford suck for fixing cars.
I will head out to A1 and check them out. Need a few little things doing I dont trust Ford with.

 

_________________

EL XR8
Timmeh banned himself from being a moderator.

Top
 Profile  
 
 
Posted: Sat Jul 30, 2005 7:32 pm 
Parts Gopher
Offline

Posts: 61

Joined: 28th Jul 2005

Location: none
QLD, Australia

Mine (sep 01 XR8 auto) does the same sort of thing idle is a little rough only having been driving for 1/2 hr. I've changed the leads and plugs (Top gun leads and titanuim plugs from repco). did the 100000k service myself from bumper to bumper, replaced belt (starting to crack) and had the shaft from the ignition module lubed tightened and checked.

any ideas what else it could be?
Top
 Profile  
 
 
Posted: Sun Jul 31, 2005 4:52 pm 
Oompa Loompa
Offline

Age: 36

Posts: 49

Joined: 9th May 2005

Ride: 300zx tt

Location: Adelaide
SA, Australia

try cleaning the throttle body and icv. did you change the fuel filter when you serviced it? tps? maf needs cleaning? leaky injectors?

 

_________________

i'm huge in japan...

Top
 Profile  
 
 
Posted: Mon Aug 01, 2005 9:57 am 
Parts Gopher
Offline

Posts: 61

Joined: 28th Jul 2005

Location: none
QLD, Australia

you may need to tell me what ICV, MAF, and TPS stand for?
I'll get a fuel filter when I'm out today and gie that a go too
Thanks
Top
 Profile  
 
 
Posted: Mon Aug 01, 2005 6:34 pm 
Oompa Loompa
Offline

Age: 36

Posts: 49

Joined: 9th May 2005

Ride: 300zx tt

Location: Adelaide
SA, Australia

icv - idle control valve
tps - throttle position sensor
these two are mounted on your throttle body. remove the throttle body, get a can of nulon throttle body cleaner or similar, remove the tps (do not clean. if tps is giving faulty readings will have to be replaced) and icv and go nuts with the cleaner on the throttle body and icv. excpect a lot of crap to come out. lots of grime builds up over time.
maf - mass air flow sensor. mounted just behind the airbox on the pipe going from the airbox to the throttle body. thin wires aer used to measure the flow of air and put aout a small voltage reading. can get dirty and give wrong readings causing rough idle, specially if you're using aftermarket oil soaked filters such as k&n. you can get a can of contact cleaner and give it a good clean.

 

_________________

i'm huge in japan...

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 7:50 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names