Fordmods Logo

oil pump hitting mains girdle 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: oil pump hitting mains girdle
Posted: Sat Feb 24, 2007 6:52 pm 
Parts Gopher
Offline

Posts: 97

Joined: 28th Aug 2006

Location: Hillside
VIC, Australia

has anybody had any problems fitting a oil pump on a stroker windsor with a mains girdle on?? as im having problems with the nut & bolt nearest to the pump, rang a couple of places with little response
thanks in advance
Top
 Profile  
 
 
Posted: Sun Feb 25, 2007 7:25 pm 
Tyre Shredder
Offline
User avatar

Age: 51

Posts: 377

Joined: 22nd May 2005

Gallery: 7 images

Ride: NF Fairlane V8

Location: Melbourne
VIC, Australia

I've just fitted together my stroker with a girdle and the way to get the pump to fit is to grind away part of the body of the pump thats in the way..

 

_________________

The TORQUE Monster project begins!

Pic's, details and all the yummy stuff:
http://www.fordmods.com/forums/viewtopic.php?t=22693

"There's no replacement for displacement!"

Top
 Profile  
 
 
Posted: Sun Feb 25, 2007 7:55 pm 
Parts Gopher
Offline

Posts: 97

Joined: 28th Aug 2006

Location: Hillside
VIC, Australia

modified part of the pump {the neck part } but the other part of the pump still touches the stud & bolt for the main girdle, are their diiferent types of nuts?? as i have already screwed 1 pump
thanks
Top
 Profile  
 
 
Posted: Sun Feb 25, 2007 8:35 pm 
Tyre Shredder
Offline
User avatar

Age: 51

Posts: 377

Joined: 22nd May 2005

Gallery: 7 images

Ride: NF Fairlane V8

Location: Melbourne
VIC, Australia

Well I'm using a Melling pump and I didn't have to do anything to the neck area. Where the Nut and Stud hit on yours is the same area I had to grind the body on mine down.

I'd take a photo but I've already bolted the sump up... :D

 

_________________

The TORQUE Monster project begins!

Pic's, details and all the yummy stuff:
http://www.fordmods.com/forums/viewtopic.php?t=22693

"There's no replacement for displacement!"

Top
 Profile  
 
 
Posted: Wed Feb 28, 2007 6:33 pm 
Parts Gopher
Offline

Posts: 97

Joined: 28th Aug 2006

Location: Hillside
VIC, Australia

went to a couple of places they suggested that you have to get a 12 point 1/2"nut and machine the stud and nut down and the body of the oil pump, have just done that problem solved
thanks for the info
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 11:36 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names