Fordmods Logo

problem with cooling system 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: problem with cooling system
Posted: Sun Jan 29, 2006 9:04 pm 
Oompa Loompa
Offline
User avatar

Age: 32

Posts: 40

Joined: 28th Oct 2005

Ride: XR8

Location: Melbourne
VIC, Australia

i have just replaced my radiator cap due to loosing water from what seemed to be the overflow but have still had problems with loosing water and not too sure where its coming from. i have to fill the resivior every couple of day any ideas i hope its nothing major

 

_________________

!POST WHORE!

Top
 Profile  
 
 
Posted: Sun Jan 29, 2006 9:08 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2449

Joined: 5th Nov 2004

Ride: Falcon EB-s

Location: Manjimup
WA, Australia

check all hoses, heater taps, radiator tanks, and things like that for leaks. Also check the water pump area as they have a tendency to cavitate and wear away. And check your oil and make sure it isnt milky! If its milky water is getting into the sump somewhere.

 

_________________

The problem with America is stupidity. I'm not saying there should be a capital punishment for stupidity, but why don't we just take the safety labels off of everything and let the problem solve itself?
Image

Top
 Profile  
 
 
Posted: Sun Jan 29, 2006 10:27 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 5924

Joined: 5th Nov 2004

Gallery: 7 images

Ride: Ford FPV FG F6 310

Power: 149 rwkw

Location: Brisbane
QLD, Australia

if you've got coolant in your system, it'll leave that white corrosion look around where it's leaking.
go over your whole coolant system thoroughly.

 

_________________

NEW RIDE - FPV FG F6 6spd Auto. 12.26@114MPH, 1.88 60FT on Cheapy Tyres with 38PSI - Stock except K&N filter!

R.I.P. BF XR6 Turbo - You will not be forgotten :( 12.06@120MPH

Top
 Profile  
 
 
Posted: Tue Jan 31, 2006 9:32 pm 
Getting Side Ways
Offline
User avatar

Age: 42

Posts: 452

Joined: 21st Dec 2004

Gallery: 1 images

Location: Adelaide
SA, Australia

Mine has just done the same. The bigggest leak was the small hose that was a 90* bend off the water pump and under the manifold to the heater. The the top radiator hose where the air bleed line taps of to the resivour.

You need to get your new hoses direct from Ford, no aftermarket manufacturer makes them. I just spent $150 on all new hoses. Working a treat now though, after months of a misterious leak.

Coincedentaly, the small 90* hose that I got for my EF using the EF parts catalogue was interesting. The sticker it had on it was "Falcon XW GTHO" and then the part number. It appears this hose has been used for 35 years or so.

 

_________________

Adrian
EF Fairmont, 5.0Lt, Pacemaker Headers, Sports cats, Redback muff, T5 manual, 16" Tickford rims, Tickford "Body Styling", DBA Gold Rotors, Heritage Green, JVC MP3
XB Coupe, 351C, twin system, C4 shift kitted auto, 9" LSD, Eccose Blue, very loud !!!!

Top
 Profile  
 
 
Posted: Wed Feb 01, 2006 4:13 am 
Parts Gopher
Offline

Age: 40

Posts: 97

Joined: 3rd Apr 2005

Ride: 98 F.B.T

Location: Ferntree Gully
VIC, Australia

Hi if your after any hose for your vehicle i work at a dearlership and can get them at very good price just send me an email at xygthoph3@optusnet.com.au
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Majestic-12 [Bot] and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 6:11 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names