Fordmods Logo

Red water jug with fan light illuminated - cooling issue? 

 

Page 1 of 1 [ 15 posts ] 

 
 Post subject: Red water jug with fan light illuminated - cooling issue?
Posted: Mon Jul 23, 2007 9:45 am 
Parts Gopher
Offline
User avatar

Posts: 84

Joined: 22nd May 2007

Ride: EF XR8

Location: SYD
NSW, Australia

Hi guys, I have an EF XR8.

I think I may have a cooling problem.

When my car is turned off, the temperature gauge needle is quite a bit below the bottom line. When I run the car, under normal driving conditions the needle barely goes into the normal area.

If I give the car a big go, it rises up to probably about 2/3

After a while mid rpm driving (such as on the freeway and giving it the gun around town), I get this light pop up of what looks like a water container, with a squiggly water line and a fan in it, it's in red.

The temperature gauge seems fine.

Sometimes I think I can smell it overheating but I cant be sure.

I pull over into the servo, undo the reservoir cap (which is always highly pressurised) and steam will come out, because of the pressure it usually will go all over the servo forecourt.

So I pour new water in (which is usually only about 1L) then drive off, the light has gone.

So all the symptoms point to an overheating problem, but the gauge seems fine, and I dont think I am giving the car a hard time.

I am thinking I might have a problem somewhere and the gauge isnt working properly?

What is the normal operation for the gauge?

Thanks for all your input

 

_________________

Wanted - boot floor and lining for sedan - cheap - Syd-Central Coast

Top
 Profile  
 
 
Posted: Mon Jul 23, 2007 12:04 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

that light is the low coolant sensor. it might be a bit dodgy lol

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Mon Jul 23, 2007 1:34 pm 
Smokin em up
Offline

Age: 35

Posts: 296

Joined: 16th Oct 2006

Ride: 94 EF (OPT20), TF Cortina Ghia

Location: Bendigo
VIC, Australia

try your dash in diagnostic mode and see what the temp says in there

 

_________________

"Look I found tape, I'm a mechanic now!!!" Mike Teutul

Top
 Profile  
 
 
Posted: Mon Jul 23, 2007 2:46 pm 
Parts Gopher
Offline
User avatar

Posts: 84

Joined: 22nd May 2007

Ride: EF XR8

Location: SYD
NSW, Australia

Hi mate, how do I go about doing that?

Cheers

 

_________________

Wanted - boot floor and lining for sedan - cheap - Syd-Central Coast

Top
 Profile  
 
 
Posted: Mon Jul 23, 2007 11:13 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 3928

Joined: 5th Nov 2004

Gallery: 9 images

Ride: ED 5 Speed GLiXR

Location: Now in Brisbane
QLD, Australia

By the sounds of it, that light your seeing is the low level coolant light, these things have been known to get s**t stuck on hem and give faulty readings, or you may actually have low coolant level.
Check out the senor, if its f**k replace it, they arent that expensive to replace.

 

_________________

17" Tezza Steelies, King F**king lows, pedders sports ryders, 2.5" cat back exhaust, pacemaker extractors, T5 manual
Low, loud and Slow

Top
 Profile  
 
 
Posted: Mon Jul 23, 2007 11:18 pm 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 831

Joined: 9th Nov 2004

Gallery: 4 images

Ride: BA XR8 & 06 4x4 Bravo

Location: Pakenham
VIC, Australia

SECTION25 wrote:
Hi mate, how do I go about doing that?

Cheers

http://www.fordmods.com/forums/documents.php?doc=12

 

_________________

Image
'04 BA XR8
Winter White, 5 Speed Manual, Sports Leather, Premium Sound, 2 1/2" Cat Back Exh - no rear Mufflers, Lowered SL/SSL, 20's, Underdrives, BF Typhoon Rear Spoiler, GT Steering Wheel, etc.

Top
 Profile  
 
 
Posted: Thu Jul 26, 2007 10:52 am 
Parts Gopher
Offline
User avatar

Posts: 84

Joined: 22nd May 2007

Ride: EF XR8

Location: SYD
NSW, Australia

Im thinking it could possibly be head gasket problem, any idea how much it would cost to replace these?

Cheers

 

_________________

Wanted - boot floor and lining for sedan - cheap - Syd-Central Coast

Top
 Profile  
 
 
Posted: Thu Jul 26, 2007 11:42 am 
Smokin em up
Offline

Age: 46

Posts: 221

Joined: 7th Jan 2006

Gallery: 2 images

Ride: F150 EL mont&2001 cobra

Location: Innisfail
QLD, Australia

Check to see if the bleed hoses aren't blocked. they are the ones that run from the header tank to the top radiator hose and to the top of the radiator.

 

_________________

Smoken the hides in top gear

Top
 Profile  
 
 
Posted: Fri Jul 27, 2007 11:43 am 
Smokin em up
Offline
User avatar

Posts: 266

Joined: 16th Feb 2007

Could also be a dodgy thermostat.
Top
 Profile  
 
 
Posted: Fri Jul 27, 2007 3:59 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Could be a pin-hole in one of your hoses that's slowly leaking onto your motor, causing the smell. Or a slow leak from the timing cover gasket which was running down the motor causing the smell which happened to mine...

It doesn't sound like the sensor's cactus if you have to top the reservoir up. I'd put my money on a slow leak somewhere...

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
Posted: Fri Jul 27, 2007 4:09 pm 
Technical Contributor
Offline
User avatar

Age: 34

Posts: 4355

Joined: 14th Dec 2005

Gallery: 36 images

Ride: Fairlane

Location: Newy
NSW, Australia

i was just about to say that scaffy, if you are putting 1L of water in when you go to the servo there must be a leak somewhere, which is what is causeing the smell (coolant dripping on engine) and also why your low coolant light is coming on (low coolant level)

Have a look around and see if you can see a leak anywhere out of the hoses, if not put some newspaper underneath the car over night and see if there is anything dripping down. if all else fails and you cant located it take it to the mechanics unless you are capable of doing some work yourself.

 

_________________

The Lane Lives.... Finally!!!!

Top
 Profile  
 
 
Posted: Tue Jul 31, 2007 5:32 pm 
Parts Gopher
Offline
User avatar

Posts: 84

Joined: 22nd May 2007

Ride: EF XR8

Location: SYD
NSW, Australia

Got a service done on the auto and the engine, doesnt seem to do it anymore, however, nothing was actually replaced in the cooling system.

A mystery?

 

_________________

Wanted - boot floor and lining for sedan - cheap - Syd-Central Coast

Top
 Profile  
 
 
Posted: Thu Aug 02, 2007 7:28 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Give it time...

Hahaha... nah mate, hopefully it will bother you no more!

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
Posted: Fri Aug 03, 2007 12:26 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 2058

Joined: 25th May 2006

Ride: ef xr8

Power: 229 rwkw

Location: Perth
WA, Australia

Just check that the thermos are coming on too. If not then it might be a relay, the relay box is behind the passenger headlight.

 

_________________

Because of Beer, Thirst is a Beautiful Thing!

'95 EF XR8 auto, Advance headers, 3" exhaust, Cobra manifold, BBK 75mm throttle body , 80MM Marauder MAF, Vortech V2 T Trim , 307 rwhp, 405 ft/lb 13.2 @ 105 MPH

Now N/A (permanent Lag) - AFR 165's, Comp XE270 cam, 1.6 RR - 269 rwhp 14.1 @ 102mph.

Top
 Profile  
 
 
Posted: Tue Aug 07, 2007 3:11 pm 
Stock as a Rock
Offline

Age: 31

Posts: 197

Joined: 3rd Dec 2005

Ride: XHII V8S Ute

Location: Darwin
NT, Australia

I've had two of those bloody relays break this year....how coincidental.

 

_________________

Pacies & single 2.5'. New manifold to come soon...

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 15 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 12:29 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names