Fordmods Logo

thermo fan problem 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: thermo fan problem
Posted: Tue Jan 19, 2010 7:43 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 7

Joined: 19th Jan 2010

Ride: ford el xr8

Location: canberra
ACT, Australia

thermo fan problem i have a el xr8 just wanting no are the fans ment to stay on after they switch on or are they ment to intermit ive replaced the temp sensor the thermostat the relays
Top
 Profile  
 
 
 Post subject: Re: thermo fan problem
Posted: Sun Jan 24, 2010 8:28 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2450

Joined: 5th Nov 2004

Gallery: 1 images

Ride: NL V8 Fairlane

Location: Sydney
NSW, Australia

I have no idea what you mean. In any case, check the thermo relay; could be stuck on.

 

_________________

There are 10 types of people in this world.
Those who know binary and those who don't.

Top
 Profile  
 
 
 Post subject: Re: thermo fan problem
Posted: Mon Jan 25, 2010 9:30 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1079

Joined: 19th May 2005

Gallery: 29 images

Ride: ELXR8 SERIES 2

Location: naracoorte
SA, Australia

do you mean while driving? fans should shut off when you reach 20kph ground speed from memory unless you have the air con on then i think they should stay on high speed.

at idle and at operating temp my fans stay on low speed constantly until you start to move.

hope this is of some help mate.

 

_________________

EL XR8 SERIES 2, 5SPD, HOT CHILLI RED, 200 ODD RWKW OF V8 FUN AND GAMES

EF XR6, 5SPD, HERITAGE GREEN, AU XR6 VCT ENGINE

VL COMMODORE, 5SPD, WHITE

BA XT, AUTO, OFFSHORE BLUE

Top
 Profile  
 
 
 Post subject: Re: thermo fan problem
Posted: Wed Jan 27, 2010 1:00 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 7

Joined: 19th Jan 2010

Ride: ford el xr8

Location: canberra
ACT, Australia

yeah they stay on when the car is not moving but cant tell if they switch off when driving?thanx for the reply it does help a bit
Top
 Profile  
 
 
 Post subject: Re: thermo fan problem
Posted: Wed Jan 27, 2010 3:48 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 1093

Joined: 29th Nov 2004

Gallery: 15 images

Ride: BA Ford Fairlane V8

Location: Lower Hunter Valley
NSW, Australia

Are you using EL fans or EF fans? Have the fans ever behaved properly, in the way that miilard describes, since you have owned your car?

 

_________________

Interested in a fair go for the Hunter-New England area of NSW?

Top
 Profile  
 
 
 Post subject: Re: thermo fan problem
Posted: Thu Jan 28, 2010 2:25 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 7

Joined: 19th Jan 2010

Ride: ford el xr8

Location: canberra
ACT, Australia

yeah there the original el fans. i did have a problem with them at the start thay wernt working at all until it got realy hot but only one fan would come on so i think there working properly now
Top
 Profile  
 
 
 Post subject: Re: thermo fan problem
Posted: Thu Jan 28, 2010 6:23 pm 
Technical Contributor
Offline
User avatar

Age: 34

Posts: 4355

Joined: 14th Dec 2005

Gallery: 36 images

Ride: Fairlane

Location: Newy
NSW, Australia

i have had a similar problem lately with fans staying on after ignition is turned off. only been happening last few weeks

 

_________________

The Lane Lives.... Finally!!!!

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 7:26 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names