Fordmods Logo

V8 Mont still has issues 

 

Page 1 of 1 [ 14 posts ] 

 
 Post subject: V8 Mont still has issues
Posted: Tue Apr 28, 2009 3:33 pm 
Tyre Shredder
Offline
User avatar

Age: 25

Posts: 327

Joined: 23rd Apr 2008

Ride: ED, EB11, 351 XF

Location: christchurch
New Zealand

I thought the TFI had crapped out but No.
After getting the dizzy back from being reconditioned and tested aswell as the coil the car still has the same problems ( Ocasianal miss and once they car has been running for a bit it stops then you have to pump the accelerator to keep it going while black smoke bellows out The back)

Not sure where to looK?
I also put a new fuel filter the first time it crapped out.
Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Tue Apr 28, 2009 4:22 pm 
Getting Side Ways
Offline
User avatar

Posts: 1427

Joined: 21st May 2005

Location: Melbourne
VIC, Australia

The black smoke you talk about bellowing out the back when it tries to die is the engine being over fuelled. Does the car continue to run after black smoke? How long before this occurs? When the dizzy was tested/reco'd , did they replace the TFI module AND the hall sensor? I have had a hall sensor cause the failure of a new TFI module.
I had something similar with my wifes car. it would start and run for anywhere from 10sec to 1min before it shut down, and it occasionally would get past the hump but then die another 5-10sec later. I bought a new dizzy from ford, been fine ever since.

It could also be something with your MAF sensor, do you use a K&N or similar oiled airfilter? Excess oiling can cause the MAF to go out of whack.

 

_________________

EL Fairmont Ghia - Manual - Supercharged
- The Car
- The Headlights

Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Tue Apr 28, 2009 4:55 pm 
Tyre Shredder
Offline
User avatar

Age: 25

Posts: 327

Joined: 23rd Apr 2008

Ride: ED, EB11, 351 XF

Location: christchurch
New Zealand

the car still runs it just misses badly and blows black smoke and bearly stays going without pumping the gass.
They fully recond it TFI, Hall and everything they could supposibly
I still recon its the dizzy because it only does it after the car has warmed up a little and the first time it did it about 3 months ago I put another dizzy in and away it went?
Now the problem has started agian?
Even with a Recond Dizzy
Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Tue Apr 28, 2009 11:49 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Get them to show you the old parts they took out of the dizzy.
Have you done a self test?
Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Wed Apr 29, 2009 1:00 pm 
Tyre Shredder
Offline
User avatar

Age: 25

Posts: 327

Joined: 23rd Apr 2008

Ride: ED, EB11, 351 XF

Location: christchurch
New Zealand

I havnt done a self test yet but i will

How much would you pay for a TFI and a Fuel pump?
Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Wed Apr 29, 2009 4:49 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 3763

Joined: 25th Nov 2004

Gallery: 6 images

Ride: EFII 5.8 NOS TerroristGhia

Power: 274 rwkw

Location: Sydney Australia
NSW, Australia

220 wil get you WALBRO intank pump, not sure on the TFI, they are the same 6cyl and V8 though
Brett

 

_________________

The Terrorist ED Retired due to RUST.
The TerrosistGhia, EF Ghia 351 EFI 5 Speed.
Millennium Falcon, Sleeper EL DOHC 6 Speed Manual EFI LPG
Member#1131
I didn't Vote for Multiculturalism, DID YOU!!!

Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Wed Apr 29, 2009 10:24 pm 
Getting Side Ways
Offline

Age: 48

Posts: 419

Joined: 16th Jan 2005

Ride: EF Ghia 5.0

Location: Adelaide
SA, Australia

A 6 cylinder TFI cost me about $85 recently from Motor Traders. Yes, the I6 TFI module will work on the V8s and is half the price. :)

Mike, Oz

 

_________________

EF Ghia 5.0 - XR8 in a tuxedo....classy, low and loud

Bordeaux Purple, Tickford kit, slammed, 18" BA XR8's, EL Ghia chrome, full leather, Pioneer audio, C&C, ABS, LSD, Crane cam, GT40P heads, high flow cats, Genie extractors, lots of woodgrain, chrome and interior lights!

Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Wed Apr 29, 2009 10:31 pm 
Getting Side Ways
Offline

Age: 49

Posts: 763

Joined: 5th Nov 2005

Ride: EF Fairmont

Location: oberon
NSW, Australia

For what it's worth try cleaning the maff before you spend more money.

 

_________________

ef fairmont ghia 5.0L
classy cruiser

Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Wed Apr 29, 2009 10:40 pm 
Getting Side Ways
Offline

Age: 48

Posts: 419

Joined: 16th Jan 2005

Ride: EF Ghia 5.0

Location: Adelaide
SA, Australia

Agreed, my first thought. Most fuelling issues seem to be caused by the MAF on the V8s. What about the fuel pressure reg? What could cause high pressure? Does a lack of vaccum make it supply high or low pressure?

Mike

 

_________________

EF Ghia 5.0 - XR8 in a tuxedo....classy, low and loud

Bordeaux Purple, Tickford kit, slammed, 18" BA XR8's, EL Ghia chrome, full leather, Pioneer audio, C&C, ABS, LSD, Crane cam, GT40P heads, high flow cats, Genie extractors, lots of woodgrain, chrome and interior lights!

Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Wed Apr 29, 2009 10:49 pm 
Getting Side Ways
Offline

Age: 36

Posts: 508

Joined: 28th Feb 2009

Gallery: 9 images

Ride: Ed v8 fairmont wagon, wr450f

Power: 137 rwkw

i get a bit of a flat spot and it fuels up abit but when i clean the maf it cleans up,i'd try the maf first like revhead and v8 ghia said
Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Thu Apr 30, 2009 12:09 am 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

duvauchellemotors wrote:
I havnt done a self test yet but i will

How much would you pay for a TFI and a Fuel pump?


A self test is the FIRST thing you should do.
Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Thu Apr 30, 2009 4:19 pm 
Tyre Shredder
Offline
User avatar

Age: 25

Posts: 327

Joined: 23rd Apr 2008

Ride: ED, EB11, 351 XF

Location: christchurch
New Zealand

Where is the MAF?
Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Thu Apr 30, 2009 7:33 pm 
Getting Side Ways
Offline

Age: 48

Posts: 419

Joined: 16th Jan 2005

Ride: EF Ghia 5.0

Location: Adelaide
SA, Australia

Its the large aluminium cylinder attached directly to the rear of the airbox lid. The air intake tube attaches to it leading to the throttle body.

Warning, be VERY careful cleaning the tiny hot wires inside this and some disassembly is required. It's an expensive mistake if you stuff it up. There is a tech doco somewhere on this site explaining how to clean it out. This often works wonders.

Mike

 

_________________

EF Ghia 5.0 - XR8 in a tuxedo....classy, low and loud

Bordeaux Purple, Tickford kit, slammed, 18" BA XR8's, EL Ghia chrome, full leather, Pioneer audio, C&C, ABS, LSD, Crane cam, GT40P heads, high flow cats, Genie extractors, lots of woodgrain, chrome and interior lights!

Top
 Profile  
 
 
 Post subject: Re: V8 Mont still has issues
Posted: Tue May 19, 2009 3:32 pm 
Tyre Shredder
Offline
User avatar

Age: 25

Posts: 327

Joined: 23rd Apr 2008

Ride: ED, EB11, 351 XF

Location: christchurch
New Zealand

The car is still off the road :(
Iv taken the MAF apart but it appears to be clean as????
any more ideas?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 14 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 8:10 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names