Fordmods Logo

Windsor Idle prob!!!! 


Page 1 of 1 [ 2 posts ] 

 Post subject: Windsor Idle prob!!!!
Posted: Sat Apr 19, 2008 2:04 am 
Getting Side Ways
User avatar

Age: 34

Posts: 613

Joined: 5th Aug 2007

Location: Ararat
VIC, Australia

My EF Ghia has a problem!

When I come to a stop say at traffic lights(still in D) the idle drops to around just under 500rpm- and sometimes it stalls- this is intermittent. It seems to only do it on GAS.

When the car is in either Park or Neutral it is fine and idles around 700-750rpm. I have adjusted my Gas idle screw- but its stil the same. And it is most noticeable when I first start the car and move off.

Other then this the car runs smooth, and returns fantastic economy on LPG- around 500'ks per 70'l's.

Any ideas?? :cry:




EF Ghia 5L V8
BAMk2 XR8 Velocity/Cobra 19's

Posted: Sat Apr 19, 2008 6:29 pm 
Getting Side Ways

Age: 31

Posts: 942

Joined: 23rd Dec 2007

Ride: AU1 XR8

Check to see if you have a vacuum leak, also the ISC might need a clean.

See if the idles screw can or needs to be adjusted, also check the TPS.

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 22, 2016 11:14 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names