Fordmods Logo

89 xf falcon ute auto 4.1 carby engine no accelaration 

 

Page 1 of 1 [ 1 post ] 

 
 Post subject: 89 xf falcon ute auto 4.1 carby engine no accelaration
Posted: Sun Apr 03, 2016 12:37 pm 
Fordmods Newbie
Offline

Age: 26

Posts: 1

Joined: 3rd Apr 2016

Ride: 1989 xf falcon ute (carby 4.1)

Location: melbourne
VIC, Australia

i have a 89 xf falcon ute stock 6 cylinder 4.1 3speed auto, carby engine that i only run on lpg, it starts on gas no problem at all range in alright it idles good, but just no power or accelaration and doesnt rev that hard at all, its not to bad once you get over 80kph but getting there it just takes foreva to get there, my kick down cable is disconected at the moment which i know is not ideal but i can still change the gears myself and didnt think it would affect it to much, the plugs and leads look alright and ive looked over the hoses and pipes roughly but nothing sticks out, any suggestions would be good cheers
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Mar 28, 2017 7:01 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names