Fordmods Logo

electrical 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: electrical
Posted: Sun Jul 22, 2007 4:37 pm 
Fordmods Newbie
Offline

Posts: 3

Joined: 20th Jul 2007

Ride: xa gt

Location: emerald
QLD, Australia

my digital dash has stopped working in a fe ltd,would it be a fuse???
Top
 Profile  
 
 
Posted: Sun Jul 22, 2007 7:29 pm 
Stock as a Rock
Offline
User avatar

Posts: 122

Joined: 25th Apr 2005

Gallery: 9 images

Ride: EL Fairmont Ghia

Location: Gold Coast
QLD, Australia

Try changing the courtesy lamp fuse for some reason it supplies power to the dash cluster as well. 8-)

 

_________________

Knower of ALL......Master of NOTHING !!!

Top
 Profile  
 
 
Posted: Mon Jul 23, 2007 6:52 pm 
Fordmods Newbie
Offline

Posts: 3

Joined: 20th Jul 2007

Ride: xa gt

Location: emerald
QLD, Australia

Thank you very much will give it a go
Top
 Profile  
 
 
Posted: Sun Jul 29, 2007 4:42 pm 
Parts Gopher
Offline

Age: 38

Posts: 61

Joined: 27th Jul 2007

Ride: XG

Location: adelaide
SA, Australia

maybe even dry solder joint on the circuit board
Top
 Profile  
 
 
Posted: Mon Jul 30, 2007 6:54 pm 
Fordmods Newbie
Offline

Posts: 3

Joined: 20th Jul 2007

Ride: xa gt

Location: emerald
QLD, Australia

thank you.. will give it a try.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 11:32 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names