Fordmods Logo

HELP. Flat Spot in XC 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: HELP. Flat Spot in XC
Posted: Sun May 14, 2006 6:59 pm 
Fordmods Newbie
Offline

Posts: 9

Joined: 29th Mar 2006

Location: Wodonga
VIC, Australia

hi, ive recently brought a 77 XC fairmont with a stock 302C, and it has a massive flat spot on accelerating. the secondary jets are clear and working. wat happens is when the foot goes to the floor, the car practically dies, nothing happens. spark plaugs are clean, electronic dizzy is also clean. i am looking for some foto's of detailed under bonnet near the carby, eg where hoses go and come from as i dont know, and i cant find any one where i am (wodonga) that has a V8. any help would be verry appriciated thank you
Top
 Profile  
 
 
 Post subject: flatspot
Posted: Sun May 14, 2006 8:44 pm 
Parts Gopher
Offline

Posts: 76

Joined: 1st Oct 2005

Location: Cairns
QLD, Australia

When you say stock does that also refer to a carter thermoquad carb or has that been changed to a holley or something ? Just asking so as to diagnose the fault.
Top
 Profile  
 
 
Posted: Mon May 15, 2006 9:32 am 
Fordmods Newbie
Offline

Posts: 9

Joined: 29th Mar 2006

Location: Wodonga
VIC, Australia

still has carter thermoquad
Top
 Profile  
 
 
Posted: Mon May 15, 2006 2:23 pm 
Getting Side Ways
Offline
User avatar

Age: 79

Posts: 1233

Joined: 7th Apr 2005

Gallery: 7 images

Ride: GTHO PH 1 EF ex chaser

Location: Willow vale, GOLD COAST
QLD, Australia

Get someone who knows what they are doing with the carter to set it up properly and you wont have this problem. The usual problem is too many D**KHEADS that think they know dont. :roll: :shock: :twisted:

 

_________________

Rotten Old Revhead!!! XW GTHO + EF ex cop car (exractors 2.5 cat back zorst !6" Simmons K&N +airbox mods Lowered with Bilstein shocks+Whiteline Bars NEXT THING Swap HO for GTP or Ferrari!

Top
 Profile  
 
 
Posted: Mon May 15, 2006 7:04 pm 
Smokin em up
Offline

Posts: 227

Joined: 11th Dec 2004

Location: Gold Coast
QLD, Australia

First of all get a can of carby clean and blast out the carby, try and give the air bleeds in the primaries a good shot.

Readjust your idle mixture screws evenly for the smoothest idle then adjust the idle speed screw as required.

Is it a bog or does it totaly die in the a*** as if its going to stall?

If it a bog then the secondary door is probably opening too fast. If its the second then the secondary jets are blocked.

vaccum hose connections will not cause acceleration issues unless the booster hose is off.

Also you should really rebuild the carby 9/10 times the fuel wells in the phenolic body are leaking.
Top
 Profile  
 
 
Posted: Tue May 16, 2006 9:44 am 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 1249

Joined: 5th Nov 2004

Ride: Falcon

Location: Melbourne
VIC, Australia

Yup will be the carbie needs a clean out, I had the same problem a few time with the old carter, a good clean out and she'll be right as rain

 

_________________

I couldnt fix your brakes so I made your horn louder
Image

Top
 Profile  
 
 
Posted: Tue May 16, 2006 6:13 pm 
Stock as a Rock
Offline
User avatar

Posts: 157

Joined: 19th Dec 2004

Location: Seaford
VIC, Australia

I'd say the accel pump is dead. Replace it and it'll work like it should again. It's common regardless of what type of carb it is.

 

_________________

XB Fairmont sedan 11.07@123.02mph

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 1:40 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names