Fordmods Logo

The FD LTD Lives... 

 

Page 4 of 6 [ 84 posts ] Go to page Previous  1, 2, 3, 4, 5, 6  Next

 
Posted: Fri Aug 17, 2007 8:51 pm 
Stock as a Rock
Offline
User avatar

Posts: 158

Joined: 23rd Sep 2006

Ride: '84 Zk Fairlane

Location: Wodonga
VIC, Australia

good to hear mate!, may just need cranking for a while longer as if it ran dry you will have alota air pockets which EFI's hate

 

_________________

ZK Fairlane Project Thread:
http://www.xfords.com/forum/showthread.php?t=2923

Image

Top
 Profile  
 
 
Posted: Fri Aug 17, 2007 9:11 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

spent a couple of mins priming the fuel lines - acc to ign (without start) then back.. then back again.. back to acc - you get the idea lol.

each time the fuel pump whirred in operation, but could tell that the tank was bone dry the first prime.

hopefully tomorrow i will have great news in that it is running :D

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Sat Aug 18, 2007 7:05 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

:D :D :D IT RUNS!!! :D :D :D
:D :D :D IT RUNS!!! :D :D :D

the LTD has LIFE :D :D

As im sure you can tell, i am very excited / happy that its now running.

Brought a few new things to go onto it today:
- new rotor cap - but took it back coz i didnt actually need it
- new dizzy
- new leads
- air filter
- oil filter
- injector cleaner

a couple of issues we have now been able to diagnose are:
- AFM Vane stickes WIDE OPEN, its been bent at some stage it seems
- the little moulded hose that runs from the top of the rocker cover under the TB has a split in it.
- the AFM metal housing has a small hole in it - only found this when i went crazy in it with some carby cleaner to get the oily crud that had formed on the surface.

we have the timing at pretty roughly dead on where it needs to be - so itl start without much convincing.

once i get the new AFM (with the black lid - learnt not to use the blue one now) all *should* be sweet.

its a good day today - she lives.

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Sat Aug 18, 2007 7:17 pm 
Stock as a Rock
Offline
User avatar

Posts: 158

Joined: 23rd Sep 2006

Ride: '84 Zk Fairlane

Location: Wodonga
VIC, Australia

awesome mate good to hear!

 

_________________

ZK Fairlane Project Thread:
http://www.xfords.com/forum/showthread.php?t=2923

Image

Top
 Profile  
 
 
Posted: Sun Aug 19, 2007 9:21 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

a VERY good weekend.

the LTD runs reasonably well - the timing is out a few degrees, but its not too far out, its liveable for the moment.

I even washed the thing today as well - looks f**k great - i was suprised at how well she came up with a bit of elbow grease and some soap suds.

its really usual to be able to get in it, flick the key over, and have her fire into life, its never done it from the day i got it - even when starting on lpg it required convincing.

when started tho (have to make sure the AFM Vane is not stuck full open) she will idle at around 800 - 900rpm, and will sit there happily for about 5mins or so, then will start to have the idle come down, start to get lumpy and then die - a stab of the accel is able to keep it alive for another 5mins.
im thinking that this is because the AFM Vane is catching at points?

oil fitler has been changed - dropped the oil - and both will be changed again soon.

heres a couple of pictures of her in her clean glory - and moved around as well:
cheers for all your help :)
<a href="http://photobucket.com" target="_blank"><img src="http://img.photobucket.com/albums/v146/doddski_03/P9200005.jpg" border="0" alt="A clean car was hiding under all that dirt and dust - needs a polish tho"></a>
<a href="http://photobucket.com" target="_blank"><img src="http://img.photobucket.com/albums/v146/doddski_03/P9200002.jpg" border="0" alt="Such a lovely clean car - the chrome came up pretty well suprisingly"></a>

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Sun Aug 19, 2007 9:43 pm 
Stock as a Rock
Offline
User avatar

Posts: 158

Joined: 23rd Sep 2006

Ride: '84 Zk Fairlane

Location: Wodonga
VIC, Australia

god there a good looking car, my fairlane does the same thing with the idol, idols fine then dies, give her a rev and its fine, i thought it may have been over fueling?

damn u you get your LTD running and my XE dies haha

 

_________________

ZK Fairlane Project Thread:
http://www.xfords.com/forum/showthread.php?t=2923

Image

Top
 Profile  
 
 
Posted: Sun Aug 19, 2007 10:51 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

rofl @ your xe dieing!
im sure youl be able to get it going again in no time.

have you found a fix for the slowly dieing idle yet in your fairlane?

im hoping that by changing the AFM for a 'newie' and setting the timing spot on itl fix it?

when shes sitting idling - i caan hear the fuel pump over the sound of the exhaust quite noticeably, should i be worrying about this?
i have a new fuel pump with tank sender (temp sender is from the ZL tho..) with the housing and all that s**t too - which il change into it soon just so that its done.

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Last edited by zk on Sun Aug 19, 2007 11:47 pm, edited 1 time in total.

Top
 Profile  
 
 
Posted: Sun Aug 19, 2007 10:55 pm 
Stock as a Rock
Offline
User avatar

Posts: 158

Joined: 23rd Sep 2006

Ride: '84 Zk Fairlane

Location: Wodonga
VIC, Australia

the xe bent 2 pushrods in a hardcore fassion
i can hear the fairlanes fuel pump quite well to - nota issue, and i thinkits just runing rich and fueling up - the reving clears it out


check out the pushrods!
http://s168.photobucket.com/albums/u166 ... 0_6984.jpg

 

_________________

ZK Fairlane Project Thread:
http://www.xfords.com/forum/showthread.php?t=2923

Image

Top
 Profile  
 
 
Posted: Sun Aug 19, 2007 10:56 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

do you have 2 turbo blades and 2 other wheels? :P

i think the turbo blades look awesome on it.

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Sun Aug 19, 2007 11:00 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

alfy wrote:
do you have 2 turbo blades and 2 other wheels? :P

i think the turbo blades look awesome on it.


yeah it has turbo blades on one side, and FD LTD rims on the drivers side.

i like the turbo blades, but im going for originality (eventually) so found a set of the FD LTD rims on ebay (along with complete interior as well)
only got around to put 2 of the good rims on... one day il put the others on.

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Mon Aug 20, 2007 7:33 pm 
Fordmods Junkie
Offline
User avatar

Age: 31

Posts: 1175

Joined: 23rd Mar 2005

Gallery: 6 images

Ride: 1994 ED Fairmont

Location: Brisbane
QLD, Australia

Thats a bloody nice looking car!!

 

_________________

1994 ED Fairmont Champaign Gold - AU Series II Intech 4.0L - EL EFI - Thermo Fans - 4.11 LSD - Pacemaker 4480 Into Custom 3" Exhaust - Shift Kit
In Progress: EL 4 Speed Auto- 3000 STALL - To be fitted
EF Tickford Race Spec Head Port- In the shop
Custom SureCam - Chiptorque

Top
 Profile  
 
 
Posted: Mon Aug 20, 2007 7:56 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

ebfairmont3.9 wrote:
Thats a bloody nice looking car!!


cheers mate, the body is 99.9% straight no dents or scratches in her and just a couple of small rust spots - but when i say small, i really do mean small.
C pillar rust is not there at all - like seriously none there.
the only rust is on the boot lid in a couple of small small spots and a bit in the boot lid on weld joins/crossmembers and the smallest amount in the driverside gutters - which i know will be a VERY hard place to get repaired but i can live with it.

pain is good - when scrubbing all the s**t that had fallen on the car from when it was under the trees, the pinstriping started to come off - no biggie really, il be getting the car resprayed back to original colour in the coming months and get the pinstriping put back on properly

The interior was is a little... 'preloved' when i got it, but it was complete.

i got this thing for a bargain price of $650 - the lady i brought it off originally wanted 1400 for it!!!
i just threw the old "shes pretty sad, needs a fair bit of work and money to get it back to RWC - the most i would be willing to give you is 600" line and she brought it - well i did. either which way, i got this thing for a bargain price, even considering the amount of work it needs and the money it needs spending on it.
i allready spent a heap on it - have everything i need to get it back to perfect condition, just have to put it all in.


i love driving past the house during the day - it looks f**k sweet just staring down the driveway at you. :P

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Tue Aug 21, 2007 12:45 am 
Fordmods Junkie
Offline
User avatar

Age: 31

Posts: 1175

Joined: 23rd Mar 2005

Gallery: 6 images

Ride: 1994 ED Fairmont

Location: Brisbane
QLD, Australia

Def a bargain man!! I rekon thats the best looking fairlane ford produced. and you got one with a body in such good nic like that!

 

_________________

1994 ED Fairmont Champaign Gold - AU Series II Intech 4.0L - EL EFI - Thermo Fans - 4.11 LSD - Pacemaker 4480 Into Custom 3" Exhaust - Shift Kit
In Progress: EL 4 Speed Auto- 3000 STALL - To be fitted
EF Tickford Race Spec Head Port- In the shop
Custom SureCam - Chiptorque

Top
 Profile  
 
 
Posted: Tue Aug 21, 2007 5:36 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

and shes dead again!

this time i know the problem - fuel pump has karked it
there is no 'hiss' from it when turning the key to ign so to me that seems like a bloody good sign its the fuel pump.
to be honest tho, took me a minute to work it out - i had it running and then a mate dropped by so turned it off and went back to the car to show him it and there was no action.

i got a nice new one sitting in the cupboard, so il get around to putting it in soon i hope.

gee with this car, if its not one thing - its another!
at least when its got fuel... it DOES run.

its all part of the bonding process im sure lol

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Tue Aug 21, 2007 9:49 pm 
Fordmods Junkie
Offline
User avatar

Age: 31

Posts: 1175

Joined: 23rd Mar 2005

Gallery: 6 images

Ride: 1994 ED Fairmont

Location: Brisbane
QLD, Australia

Just an old car man and if it was ever sitting for a period of time.. that kills things.

 

_________________

1994 ED Fairmont Champaign Gold - AU Series II Intech 4.0L - EL EFI - Thermo Fans - 4.11 LSD - Pacemaker 4480 Into Custom 3" Exhaust - Shift Kit
In Progress: EL 4 Speed Auto- 3000 STALL - To be fitted
EF Tickford Race Spec Head Port- In the shop
Custom SureCam - Chiptorque

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 4 of 6  [ 84 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 9:50 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names