Fordmods Logo

xg oil pressure problem 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: xg oil pressure problem
Posted: Thu May 27, 2010 11:41 pm 
Fordmods Newbie
Offline

Age: 26

Posts: 3

Joined: 6th Apr 2010

Ride: xg xr6 ute

Location: western australia
WA, Australia

hey guys i have an xg xr6 and lately the oil pressure gage has been going up and down, when its in first gear it almost hits max pressure then shoots back down again. any ideas? cheers
Top
 Profile  
 
 
 Post subject: Re: xg oil pressure problem
Posted: Fri May 28, 2010 8:50 pm 
Getting Side Ways
Offline

Posts: 790

Joined: 18th Mar 2005

Gallery: 4 images

Location: Adelaide
SA, Australia

obvious sounding but what is your oil level like - and when was it last changed? Also, hm pressure are you getting at idle?

 

_________________

351 4V XB Coupe running LPG

Top
 Profile  
 
 
 Post subject: Re: xg oil pressure problem
Posted: Tue Jun 01, 2010 1:18 pm 
Fordmods Newbie
Offline

Age: 26

Posts: 3

Joined: 6th Apr 2010

Ride: xg xr6 ute

Location: western australia
WA, Australia

i recently changed the oil and filter and the pressure has dropped a small amount, but its still nearly reaching max when im in first gear, its a four speed auto so it drops when it changes up to second. just cant figure out why its doin it and at idle its sitting at normal.
Top
 Profile  
 
 
 Post subject: Re: xg oil pressure problem
Posted: Tue Jun 01, 2010 1:35 pm 
Getting Side Ways
Offline

Posts: 790

Joined: 18th Mar 2005

Gallery: 4 images

Location: Adelaide
SA, Australia

Could be on the wrong track here but are you absolutely sure you've got the right oil filter? I mean, obviously the one you have fits, but I had a prob years ago like this and it was either there WAS a pressure relief valve in the filter and there shouldn't have been, or the other way around... in that case, the filter physically fit the motor but it was wrong...

 

_________________

351 4V XB Coupe running LPG

Top
 Profile  
 
 
 Post subject: Re: xg oil pressure problem
Posted: Tue Jun 01, 2010 1:39 pm 
Fordmods Newbie
Offline

Age: 26

Posts: 3

Joined: 6th Apr 2010

Ride: xg xr6 ute

Location: western australia
WA, Australia

yeh deffinitely have the right filter on there, just strange that its all of a sudden started doing it. there arent any leaks from the gaskets and its not blowing smoke. really stuck on what it could be.
Top
 Profile  
 
 
 Post subject: Re: xg oil pressure problem
Posted: Tue Jun 01, 2010 1:53 pm 
Getting Side Ways
Offline

Posts: 790

Joined: 18th Mar 2005

Gallery: 4 images

Location: Adelaide
SA, Australia

I mean,
oil pressure, of course, DOES go up with revs - are you saying it goes to a higher point on the guage with revs than it did previous to the oil change? (or drops at idle to a lower point than it did previously?) If yes, by how much has it changed exactly?

Did you use a different brand of oil (or maybe different viscosity rating, e.g. 20w-50 )

 

_________________

351 4V XB Coupe running LPG

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 4:12 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names