Fordmods Logo

Auto reverse problem 


Page 1 of 1 [ 2 posts ] 

 Post subject: Auto reverse problem
Posted: Sun Jul 27, 2008 9:53 am 
Fordmods Newbie

Posts: 3

Joined: 14th Jul 2006

Ride: EF

Location: melbourne
VIC, Australia

Hi! I have an EL 6 with an auto tarns. It won't drive properly in reverse, just seems to slip. I know the older Holdens used to have a problem with reverse if the trans filter was dirty but drove OK in forward gears, Is there any chance a service and filter change might fix the problem on the EL? or is it just stuffed? I don't really want to waste money on doing an oil and filter change if it's just likely to be a waste of time. If the trans is stuffed, any idea what a rebuild might cost and a good place to get it dome around Melbournes Eastern suburbs?

Posted: Wed Aug 06, 2008 2:13 am 
Getting Side Ways
User avatar

Age: 38

Posts: 412

Joined: 26th Jan 2007

Gallery: 16 images

Ride: EA

Location: vic
VIC, Australia

dont know if there the same as a three speed in a ea 1988 but mine was doing the same thing i got mine fixed with the O ring cost me about $129
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sun Oct 23, 2016 2:31 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names