Fordmods Logo

Clutch Issue Help?! 


Page 1 of 1 [ 2 posts ] 

 Post subject: Clutch Issue Help?!
Posted: Wed Aug 05, 2009 1:51 pm 
Tyre Shredder

Posts: 376

Joined: 5th Feb 2009

Ride: Ford Falcon XG

Location: Bendigo
VIC, Australia

Hi Guys,

Got a bit of an issue hopefully someone can help me out with. Clutch is playing up, when it happened i pushed clutch in and felt something unusual happen. After that clutch was quite loose and i would have to completely let my foot off for the clutch to come out.

Checked firewall hasnt pulled through, advusted clutch cable which tightened padel a bit but still have to completely let pedal go for clutch to come out. Clutch is also slipping in 2nd and 3rd gear...

Any ideas of what this could be and possible solutions??? Cheers
 Post subject: Re: Clutch Issue Help?!
Posted: Wed Aug 05, 2009 2:57 pm 
Getting Side Ways
User avatar

Age: 48

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

Sounds like what happened to me years ago...the diaphram spring broke in the pressure need another clutch. Also check the rubber insulator on the clutch fork.



Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: Google [Bot], phongus and 16 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Fri Oct 21, 2016 12:04 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names