Fordmods Logo

clutch pedal rough/grinding- new clutch kit 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: clutch pedal rough/grinding- new clutch kit
Posted: Sat Aug 16, 2008 9:00 pm 
Parts Gopher
Offline

Posts: 86

Joined: 20th Apr 2008

Location: perth
WA, Australia

Hey guys, i installed my new xtreme clutch kit the other day including new thrust bearing.
At first the clutch was sweet smooth as, now what i have found 2 days later is that it is still really smooth with the car off or just idling BUT with some revs pushing the clutch pedal in (and letting it out) is really rough and jerky sorta.
i have a pretty good feeling that this is the thrust bearing playing up but i dont understand why since it is brand new... could this be the bearing just weaing its spot in the pressure plate springs and will go away soon or is it more likely something i have done wrong (quite possible as i am no expert haha) but i mean there is only one way it can go in....

Any thoughts and help would be great!!
thanks heaps
Damien

 

_________________

El xr6
14.268 @ 96.77mph--- motorplex 4/3/08

549 crow cam
chiptorque chip
pacemakers
hiflo cat
cai w/ k&n panel filter
3.89:1 diff gears

Top
 Profile  
 
 
Posted: Wed Aug 27, 2008 1:56 am 
Parts Gopher
Offline

Posts: 86

Joined: 20th Apr 2008

Location: perth
WA, Australia

hey guys,

pulled the clutch out again today so i could try and see what has been going on and nothing really stands out i am unsure what the problem is...

there are 2 things that i think it may be (bare in mind it hasnt become any worse since the problem started)
- spigot bearing, BUT could a stuffed spigot bearing cause the symptoms i am experiencing??

- thrust bearing, from having the release bearing on the bench it seems fine, not rough at all but i am unsure if this is just because we cannot simulate the same amount of pressure at the pressure plate does. it seems to have worn grooves into the teeth (i think they are called teeth) on the pressure plate, could this be from it jamming up a little or is it normal for only after 2 weeks.

Any other ideas/help would be much appreciated!

thanks a million in advance!
Dame

 

 

Attachments:
26082008209.JPG
26082008209.JPG [ 158.18 KiB | Viewed 592 times ]

 

_________________

El xr6
14.268 @ 96.77mph--- motorplex 4/3/08

549 crow cam
chiptorque chip
pacemakers
hiflo cat
cai w/ k&n panel filter
3.89:1 diff gears

Top
 Profile  
 
 
 Post subject: Re: clutch pedal rough/grinding- new clutch kit
Posted: Tue Jul 14, 2009 12:35 pm 
Getting Side Ways
Offline
User avatar

Age: 44

Posts: 3805

Joined: 22nd Apr 2007

Gallery: 5 images

Ride: DENTED UP OLD AUT WAGON

Location: Wellington
New Zealand

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 8:30 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names