Fordmods Logo

EB 4 speed wont hold gears 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: EB 4 speed wont hold gears
Posted: Sun Jul 18, 2010 10:05 pm 
Stock as a Rock
Offline

Age: 29

Posts: 145

Joined: 24th May 2010

Gallery: 3 images

Ride: EB Ghia

Location: Ballarat
VIC, Australia

I don't know anything about these autos. Basically if i put it back to first. Idle along at 40 it'll gear up to 4th slowly. Then i touch the accelerator like a cm and it slams back into first and as soon as i take it off it gears back up. I'm not sure if there's a problem with it or it's just the GLi tune?
I know my EL XR6 used to compression lock and smash around in the gear you selected for ages before it decided to do this.
My eb has done near 300ks. There was one owner before me. He serviced the box every 20,000ks. It drives great, never randomly drops out or anything but..
Yeah could there be a problem or it's just a sake of getting a j3 tuned like an xr to hold gears longer?
I can't be fagged searching for hours to find that it's normal anyway so any help would be great.
Cheers in advance.
Top
 Profile  
 
 
 Post subject: Re: EB 4 speed wont hold gears
Posted: Mon Jul 19, 2010 7:36 pm 
Stock as a Rock
Offline

Age: 33

Posts: 141

Joined: 17th Jun 2006

Ride: Falcon

Location: canberra
ACT, Australia

Could be a Throttle Position Switch fault. Have you checked it for codes?

 

_________________

Fords Rule. OK.

Top
 Profile  
 
 
 Post subject: Re: EB 4 speed wont hold gears
Posted: Mon Jul 19, 2010 7:38 pm 
Stock as a Rock
Offline

Age: 33

Posts: 141

Joined: 17th Jun 2006

Ride: Falcon

Location: canberra
ACT, Australia

Could be a Throttle Position Switch fault. Have you checked it for codes?

 

_________________

Fords Rule. OK.

Top
 Profile  
 
 
 Post subject: Re: EB 4 speed wont hold gears
Posted: Mon Jul 19, 2010 8:35 pm 
Stock as a Rock
Offline

Age: 29

Posts: 145

Joined: 24th May 2010

Gallery: 3 images

Ride: EB Ghia

Location: Ballarat
VIC, Australia

What do you mean by codes?
Top
 Profile  
 
 
 Post subject: Re: EB 4 speed wont hold gears
Posted: Mon Jul 19, 2010 8:53 pm 
Stock as a Rock
Offline

Age: 33

Posts: 141

Joined: 17th Jun 2006

Ride: Falcon

Location: canberra
ACT, Australia

faults. the ecu logs faults when sensors, etc play up.

 

_________________

Fords Rule. OK.

Top
 Profile  
 
 
 Post subject: Re: EB 4 speed wont hold gears
Posted: Tue Jul 20, 2010 12:41 am 
Stock as a Rock
Offline

Age: 29

Posts: 145

Joined: 24th May 2010

Gallery: 3 images

Ride: EB Ghia

Location: Ballarat
VIC, Australia

I tried asking the ecu what the problem was but it just told me to f**k off!
lol na i'm not even going to pretend i have the know how or gadgets to do that.
Top
 Profile  
 
 
 Post subject: Re: EB 4 speed wont hold gears
Posted: Wed Jul 21, 2010 2:38 pm 
Stock as a Rock
Offline

Age: 29

Posts: 145

Joined: 24th May 2010

Gallery: 3 images

Ride: EB Ghia

Location: Ballarat
VIC, Australia

Well whatever you where on about the ecu, that was the problem.
I got an EL ecu today and banged it in. it's 50% better with it, Hold it heaps longer
Top
 Profile  
 
 
 Post subject: Re: EB 4 speed wont hold gears
Posted: Tue Jul 27, 2010 2:28 pm 
Stock as a Rock
Offline
User avatar

Age: 26

Posts: 111

Joined: 13th Apr 2009

Ride: AUII XR6, EBII XR6

Location: Adelaide
SA, Australia

slammeb wrote:
I know my EL XR6 used to compression lock and smash around in the gear you selected for ages before it decided to do this.


I can second that, my EB used to lock up when you threw it back into 1st doing like 40 or 50 it was scary when it used to jump out to the side lol and i could hold second til like 100km/h and it would bounce off the limiter without shifting. Definitely something not right with your picture... It doesnt have anything to do with the ECU?

 

_________________

EBII S XR6: 5 Speed short shifter, 4499s, gutted cat, 2.5" Redback, K&N Pod.
AUII XR6: 5 speed, King Super Low Rears.

Top
 Profile  
 
 
 Post subject: Re: EB 4 speed wont hold gears
Posted: Tue Jul 27, 2010 10:59 pm 
Stock as a Rock
Offline

Age: 29

Posts: 145

Joined: 24th May 2010

Gallery: 3 images

Ride: EB Ghia

Location: Ballarat
VIC, Australia

Quote:
I can second that, my EB used to lock up when you threw it back into 1st doing like 40 or 50 it was scary when it used to jump out to the side lol and i could hold second til like 100km/h and it would bounce off the limiter without shifting. Definitely something not right with your picture... It doesnt have anything to do with the ECU?

Yeah itwas, i got a EL ecu as i'm getting a j3 aswell, put it in last week and it goes heaps better, holds gears to long for what i'm used to now lol, have to tap the pedal to get it to kick down at 40+ though. Still alot better
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 8:34 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names